jakarta-bsf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Winga...@schneider.com
Subject Re: NetRexx 2.x / BSF2.3 issue getting "current" BSFManager instance...
Date Fri, 10 Jan 2003 23:12:02 GMT

It looks like your examples, and the tutorial link you sent
(thanks, I'd not seen that before and it was helpful) are all
for ObjectRexx, and I am trying to use (at the suggestion of the
Jakarta home page for BSF) NetRexx.  Interestingly, some
of the syntax does work anyway, but in no case can I get my
NetRexx script to resolve anything but a type I'm trying to
pass in from Java. The type does come "for free", or rather more
likely,  courtesy of the declareBean() call, and as one of the
other tutorials warns seems to be case-insensitive, which was
a problem, since I was following a Java convention of sorts:

TYPENAME:          Invoice
OBJECTNAME:    invoice

So, this was bound to cause confusion.  I fixed that, but this
still doesn't solve the problem.   Also, I tried call() rather than
eval() or exec(), since the link you sent describes call() in such
a way that it would seem to do exactly what I want, but alas I got
a message saying that the BSFEngine for NetRexx does not yet
support this.

Q: Is there a BSFEngine for ObjectRexx which will be supported
     going forward?  Should I switch from NetRexx to ObjectRexx?

Keith
--------------------------------------------
W. Keith Wingate
Schneider Logistics
708-647-4346
WingateK@Schneider.com



                                                                                         
                               
                    "Rony G. Flatscher"                                                  
                               
                    <Rony.Flatscher@wu-w       To:     Bean Scripting Framework users <bsf-user@jakarta.apache.org>
     
                    ien.ac.at>                 cc:                                    
                                  
                                               Fax to:                                   
                               
                    01/10/2003 01:55 AM        Subject:     Re: NetRexx 2.x / BSF2.3 issue
getting "current" BSFManager  
                    Please respond to           instance...                              
                               
                    "Bean Scripting                                                      
                               
                    Framework users"                                                     
                               
                                                                                         
                               
                                                                                         
                               




Keith:

> I've tried the syntax in the example, in fact I just tried
> it again to make sure, and NetRexxC chokes on
> the reference to bsf.  It cannot resolve it.   The only
> thing I'm importing other than my own stuff is:
>
>      import org.apache.bsf.BSFManager
>
> though, so maybe I'm missing something.  I've also
> tried skipping the lookupBean() all together, which is
> what the docs suggest you should be able to do when
> you call declareBean() from Java.  This also fails.
>
> Clearly I'm missing something, but your examples
> look very interesting, and maybe looking thru that
> will help.
>

Hmm, maybe (just a guess) your NetRexx scripts are not invoked via BSF?

This is what you would need to do to invoke a standalone NetRexx program
from a Windows command line for IBM's BSF:

    java com.ibm.bsf.Main -mode exec -lang netrexx -in %1

Just adapt the package name to Apache's.

If it's the first time you use BSF then you might skim over this article:

> <
http://wi.wu-wien.ac.at/rgf/rexx/orx12/JavaBeanScriptingWithRexx_orx12.pdf
>)
>

Also, the enhanced version of my bsf4rexx (to be ported to Apache BSF) for
alpha testing (including sources and samples)
can be downloaded from:

    http://wi.wu-wien.ac.at/rgf/rexx/bsf4rexx/

Eventually this version will be moved to sourceforge for those people who
have the IBM version deployed.

Hope that helps,

---rony



--
To unsubscribe, e-mail:   <mailto:bsf-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:bsf-user-help@jakarta.apache.org>






Mime
View raw message