jakarta-jcs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Smuts <aasm...@wisc.edu>
Subject RE: compiling for jdk 1.3
Date Fri, 16 Jul 2004 03:46:08 GMT
The core src directory now compiles under JDK 1.3.  

The jcs-1.0-dev.jar in the tempbuilds directory is compiled under 1.3.  

I created another directory in cvs under auxiliary-builds called jdk14.
I move the Berkeley DB and the LHRLRU stuff there.  That's all the code
that was 1.4 dependent.  

Under this directory

http://cvs.apache.org/viewcvs.cgi/jakarta-turbine-jcs/tempbuild/

you will find two jars:

http://cvs.apache.org/viewcvs.cgi/jakarta-turbine-jcs/tempbuild/jcs-1.0-
dev-jdk14-ext.jar

and 

http://cvs.apache.org/viewcvs.cgi/jakarta-turbine-jcs/tempbuild/jcs-1.0-
dev.jar

The first contains the 1.4 specific auxiliaries, the second everything
else compiled under 1.3.

I will continue to compile the core under 1.3 until it is obsolete.  

Cheers,

Aaron Smuts


> -----Original Message-----
> From: Dave Brondsema [mailto:dave@brondsema.net]
> Sent: Thursday, July 15, 2004 12:12 PM
> To: Turbine JCS Developers List
> Subject: RE: compiling for jdk 1.3
> 
> On Wed, 14 Jul 2004, Aaron Smuts wrote:
> 
> I just tried revisions 1.9 through 1.12 of that and I get:
> 
> java.lang.UnsupportedClassVersionError:
> org/apache/jcs/access/exception/CacheException (Unsupported
major.minor
> version 48.0)
> 
> Revision 1.8 works.  However, we need to use a recent version to avoid
an
> intermittent bug.
> 
> Thanks,
> Dave Brondsema
> 
> > I'm running the 1.4 build on a 1.3 jdk.
> >
> > This jar should work:
> >
> >
http://cvs.apache.org/viewcvs.cgi/jakarta-turbine-jcs/tempbuild/jcs-1.0-
> > dev.jar
> >
> > A couple builds back it worked fine.
> >
> > I build this jar every time I make changes.  I'm trying to keep the
core
> > of JCS 1.4 compatible.
> >
> > I guess it would be good for people to be able to build JCS with a
1.3
> > JDK, but it is more important that they be able to run it.
> >
> > Aaron
> >
> > > -----Original Message-----
> > > From: James Taylor [mailto:james@jamestaylor.org]
> > > Sent: Wednesday, July 14, 2004 1:38 PM
> > > To: Turbine JCS Developers List
> > > Subject: Re: compiling for jdk 1.3
> > >
> > > > For Forrest I would like to use a java 1.3 compatible jar file.
To
> > > > build
> > > > JCS this way, I had to remove the classes, configuration, and
tests
> > > > for:
> > > > BDBJE and LHMLRUMemoryCache.  Since these don't seem to be
required
> > > > parts
> > > > of JCS, would you consider providing some configuration (or at
least
> > > > documentation) for building JCS for java 1.3?
> > >
> > > (not an answer to the question)
> > >
> > > This is another reason why I think build modularity is a good
idea. If
> > > these optional pieces are separate builds with their own jars,
people
> > > without the requisite JDK can just not build them.
> > >
> > >
> > >
---------------------------------------------------------------------
> > > To unsubscribe, e-mail:
turbine-jcs-dev-unsubscribe@jakarta.apache.org
> > > For additional commands, e-mail:
> > turbine-jcs-dev-help@jakarta.apache.org
> >
> >
> >
---------------------------------------------------------------------
> > To unsubscribe, e-mail:
turbine-jcs-dev-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail:
turbine-jcs-dev-help@jakarta.apache.org
> >
> >
> 
> --
> Dave Brondsema : dave@brondsema.net
> http://www.brondsema.net : personal
> http://www.splike.com : programming
> http://csx.calvin.edu : student org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: turbine-jcs-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail:
turbine-jcs-dev-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: turbine-jcs-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: turbine-jcs-dev-help@jakarta.apache.org


Mime
View raw message