james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Burkey <cbur...@einnovation.com>
Subject 2.0a1
Date Fri, 26 Oct 2001 19:39:42 GMT
Hi Everyone,

	Trying to use the new version here with mysql. It almost worked except I 
got this:

Started NNTP Server plain:119
Exception: JVM_recv in socket input stream read (code=10004)
java.net.SocketException: JVM_recv in socket input stream read (code=10004)
         at java.net.SocketInputStream.socketRead(Native Method)
         at java.net.SocketInputStream.read(SocketInputStream.java:86)
         at java.net.SocketInputStream.read(SocketInputStream.java:67)
         at java.io.InputStreamReader.fill(InputStreamReader.java:173)
         at java.io.InputStreamReader.read(InputStreamReader.java:249)
         at java.io.BufferedReader.fill(BufferedReader.java:139)
         at java.io.BufferedReader.readLine(BufferedReader.java:299)
         at java.io.BufferedReader.readLine(BufferedReader.java:362)

Here is what I did to reproduce this:

1. Installed 2.0a1 from the tar file.
2. Started it up with run.bat
3. Changed the config file to use a mysql database for the inboxes. (see 
4. Telnet to 4555 and added a user cburkey with a password.
5. Sent an email to cburkey@localhost. It accepted the email. I looked in 
the mysql database and my email is in there. So far so good.
7. Tried to check my mail via pop3 and Eudora tells me:
"Error reading from the network    Cause: Connection closed by foreign 
host. (0)
There has been an error transferring your mail: I said:      STAT    and 
the POP server (cburkey@localhost) said: ERR Error closing connection"	
8. So I then tried to use Outlook Express to check the mail. There was no 
error reported but it also did not download my mail for me.
9. So I sent another email into the SMTP server and that is when I got the 
stack trace pasted above.

Looks like there is something wrong with the pop3 server. I did not see 
anything good in the log files. Can someone who has this working send me 
their config files?

View raw message