james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Danny Angus" <da...@apache.org>
Subject RE: building and running problems with cvs and latest build
Date Fri, 20 Sep 2002 14:18:37 GMT
let me look, it may be broken...

> -----Original Message-----
> From: Stefano Debenedetti [mailto:ste@webaccess.mozquito.com]
> Sent: 20 September 2002 15:02
> To: James Developers List
> Subject: building and running problems with cvs and latest build
>
>
> Hello all,
>
> I have the following problems:
>
> 1) checked out cvs last night, compiles fine and runs fine until I try
> to establish an SMTP or POP connection, here are the logs, respectively:
>
> 20/09/02 02:00:44 DEBUG smtpserver: Command received: AUTH PLAIN
> AHN0ZQBzdGljYXp6aQ==
> 20/09/02 02:00:44 DEBUG smtpserver: Exception opening socket: Exception
> retrieving Userjava.lang.RuntimeException: Exception caught while
> retrieving an object: java.lang.ClassNotFoundException:
> org.apache.james.userrepository.DefaultJamesUser
> java.lang.RuntimeException: Exception retrieving
> Userjava.lang.RuntimeException: Exception caught while retrieving an
> object: java.lang.ClassNotFoundException:
> org.apache.james.userrepository.DefaultJamesUser
> 	at
> org.apache.james.userrepository.UsersFileRepository.test(UsersFile
> Repository.java:252)
> 	at
> org.apache.james.smtpserver.SMTPHandler.doAUTH(SMTPHandler.java:542)
> 	at
> org.apache.james.smtpserver.SMTPHandler.parseCommand(SMTPHandler.java:357)
> 	at
> org.apache.james.smtpserver.SMTPHandler.handleConnection(SMTPHandl
> er.java:234)
> 	at
> org.apache.avalon.cornerstone.blocks.connection.ConnectionRunner.r
> un(Connection.java:169)
> 	at
> org.apache.avalon.excalibur.thread.impl.ExecutableRunnable.execute
> (ExecutableRunnable.java:47)
> 	at
> org.apache.avalon.excalibur.thread.impl.WorkerThread.run(WorkerThr
> ead.java:80)
>
> 20/09/02 01:59:46 DEBUG pop3server: Command received: PASS <password
> omitted>
> 20/09/02 01:59:46 ERROR pop3server: Exception during connection from
> pD9E4F2F6.dip.t-dialin.net (217.228.242.246) : Exception retrieving
> Userjava.lang.RuntimeException: Exception caught while retrieving an
> object: java.lang.ClassNotFoundException:
> org.apache.james.userrepository.DefaultJamesUser
> java.lang.RuntimeException: Exception retrieving
> Userjava.lang.RuntimeException: Exception caught while retrieving an
> object: java.lang.ClassNotFoundException:
> org.apache.james.userrepository.DefaultJamesUser
> 	at
> org.apache.james.userrepository.UsersFileRepository.test(UsersFile
> Repository.java:252)
> 	at
> org.apache.james.pop3server.POP3Handler.doPASS(POP3Handler.java:378)
> 	at
> org.apache.james.pop3server.POP3Handler.parseCommand(POP3Handler.java:318)
> 	at
> org.apache.james.pop3server.POP3Handler.handleConnection(POP3Handl
> er.java:206)
> 	at
> org.apache.avalon.cornerstone.blocks.connection.ConnectionRunner.r
> un(Connection.java:169)
> 	at
> org.apache.avalon.excalibur.thread.impl.ExecutableRunnable.execute
> (ExecutableRunnable.java:47)
> 	at
> org.apache.avalon.excalibur.thread.impl.WorkerThread.run(WorkerThr
> ead.java:80)
>
> 2) So I resorted to latest build (2002-09-19) but I had the same problem
> I had with the previous latest:
>
> BUILD FAILED
>
> C:\james\cvs\latest\build.xml:137: C:\james\cvs\latest\phoenix-bin\lib
> not found
>
> 3) last thing I tried before rolling back was to copy phoenix-bin dir
> from the cvs tree to the latest build tree, compiles fine but at startup
> time I get stuck here:
>
> Phoenix 4.0beta
>
> Target file does not exist, defaulting to previous
> Shutting down Phoenix.
>
> As usual any hint would be greatly appreciated, thanks ciao
> ste
>
>
>
> --
> To unsubscribe, e-mail:
<mailto:james-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:james-dev-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:james-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:james-dev-help@jakarta.apache.org>


Mime
View raw message