james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17980] - Attachments are sometimes not extracted on the mail client
Date Fri, 14 Mar 2003 06:32:23 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17980>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17980

Attachments are sometimes not extracted on the mail client





------- Additional Comments From Marc@deoliveira.dk  2003-03-14 06:32 -------
I have done some testing and I found out that the recipients that did not get 
correct attachments were recipients where I tried to add a footer using the 
class "AddFooter" in a two-mailet combination, like this:

         <mailet match="RecipientIs=marc@deoliveira.dk" class="AddFooter">
           <text>-----------------------------------
Some footer text
----------------------------------
           </text>
         </mailet>

         <mailet match="RecipientIs=marc@deoliveira.dk" class="Redirect">
           <recipients>deoliveira_marc@deoliveira.dk</recipients>
           <to>marc@deoliveira.dk</to>
           <inline>unaltered</inline>
           <passThrough>FALSE</passThrough>
         </mailet>

If I remove the first mailet, the attachments work fine.

- Marc

---------------------------------------------------------------------
To unsubscribe, e-mail: james-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: james-dev-help@jakarta.apache.org


Mime
View raw message