james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hontvari Jozsef" <hontva...@solware.com>
Subject Re: Processor naming thoughts?
Date Mon, 14 Apr 2003 17:16:50 GMT
setState was definitely confusing to me. It should be renamed to be
consistent with the term used for the processor/que.


----- Original Message -----
From: "Serge Knystautas" <sergek@lokitech.com>
To: <james-dev@jakarta.apache.org>
Sent: Monday, April 14, 2003 6:07 PM
Subject: Processor naming thoughts?


> Watching some of the threads of people trying to understand how mailets
> work and how messages get processed, I was thinking maybe we should
> rename "processor" to "queue".
>
> By changing the name from the verb (process) to the noun (queue), I
> think it will help people understand what is happening.  It seems one of
> the big points of confusion is, "what does it mean to send a message to
> a processor?"  Instead, "send a message to a queue" seems more
> understandable.
>
> Also then on the mailet API we should change setState() to setQueue()
> since that's what we really mean.
>
> Any thoughts?
>
> --
> Serge Knystautas
> President
> Lokitech >> software . strategy . design >> http://www.lokitech.com
> p. 301.656.5501
> e. sergek@lokitech.com
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: james-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: james-dev-help@jakarta.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: james-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: james-dev-help@jakarta.apache.org


Mime
View raw message