james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert J Taylor <rob...@rjamestaylor.com>
Subject Re: JAMES is stopping to process mails
Date Thu, 13 May 2004 02:36:54 GMT
Your version of James?

The 2.1.x series has a thread problem. Bad. Unsolved until the 2.2.x 
series, according to the developers.

In my meagre experience I set the spool threads to 1 and restart until 
the queue is down; delete hopelessly message_state="error" messages 
(impossible addresses like joe@aol, or john@ibm.cm; virus-laden email, 
non-resolving DNS domain names, etc.). Once the queue is down, reset the 
threads to something reasonable and restart.

Get's ya through it.


Robert J Taylor
robert@rjamestaylor.com

Freddy wrote:

> Hi,
>     I implanted a system that uses james to send mails.
>     This error ocurred three times:
>      james has stopped to process mails, the list of mails in the 
> spool was growing up, but no mail was processed or sended. We restart 
> james and it start to process the mails again. And we see no error 
> messages...
>     (to process a mail means: the mailet execute, and the mail go to 
> the outgoing)
>  
>     We are sending a lot of emails via james (1 sometimes 2 for a 
> second...).
>  
>     Do Somebody know what could happened? or how can I discovered what 
> happened?
> []s
> Freddy
> ----------------------------------------------------------------
> Frederico Silva GuimarĂ£es
> Tel: (21) 9952-1717
> ICQ: 127277403
> Email: kid@teccomm.les.inf.puc-rio.br 
> <mailto:kid@teccomm.les.inf.puc-rio.br>
> ----------------------------------------------------------------


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message