james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Andersson ...@ofs.no>
Subject bug in james 2.2.0 remotedelivery?
Date Thu, 15 Jul 2004 08:18:39 GMT
hi there, I just want to ask if this is a bug, or if i have just tried 
to use james v2.2.0 in a way that it should not be used..

I'm running james on a fixed ip but some external mail-servers does not 
allow me to send mail to them because my fixed ip sits inside an 
dhcp-pool for that reason I have set up james to send all outgoing mails 
through my isp:s mailserver (gateway), and here is the problem.. (I have 
found a sollution to the problem also)

every mail I'm sending out is comming through, however, they are not 
comming through with their body, just the headers and the body is empty
(for example this mailing list complained that it needs a body of 
atleast 2 chars in size)

the problem and the sollution is as following..

I HAD set up the following

<mailet match="All" class="RemoteDelivery">
             <outgoing> dbfile://maildb/spool/outgoing </outgoing>

... whick worked great for mails that was sent directly to their hosts 
(before I set up the gateway directive in james)

when I changed the <outgoing>.. to use db instead of dbfile

<outgoing> db://maildb/spool/outgoing </outgoing>

everything worked great.

Is it supposed to be like this, or is it a bug? (in that case I'll try 
to add it to jira

/Christian andersson

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message