james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Heath <m...@cycletime.com>
Subject Re: JAMES ... now that we (may be) merged, where to?
Date Wed, 04 May 2005 17:00:28 GMT
On Tue, 2005-05-03 at 22:11 -0400, Noel J. Bergman wrote:
> > Were we thinking of requiring JDK 1.4 for James 3.0?  If so, we could 
> > move to using java.util.regex, eh?
> 
> I would like to get this version stable, and we can branch it as a JDK
> 1.3 branch, so that we'll have something good for people still stuck
> on JDK 1.3.  Then we can look at moving mainstream development (trunk)
> to require JDK 1.4.

If James is to use Mina and is to support TLS, we'll have to use JDK
1.5.  Obviously *I* would like to see James incorporate my Mina based
SMTP handler.

I would also like to see annotations make there way into the mailet API.
I think annotated mailets could simplify a lot of things for the
developer.

<snip>

-Mike

BTW - I should have support for STARTTLS finished tonight or tomorrow.



---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message