james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tony Freeman (JIRA)" <server-...@james.apache.org>
Subject [jira] Commented: (JAMES-460) Running James as an NT service
Date Fri, 24 Mar 2006 18:58:49 GMT
    [ http://issues.apache.org/jira/browse/JAMES-460?page=comments#action_12371781 ] 

Tony Freeman commented on JAMES-460:
------------------------------------

Ok, Started with the last suggestion...
1st Tried:
wrapper.java.additional.1=-Djava.ext.dirs=../lib 
wrapper.java.additional.2=-Djava.ext.dirs=../tools/lib
wrapper*.3 etc...
Did not work; JVM could not find files in the first directory

2nd Tried:
wrapper.java.additional.1=-Djava.ext.dirs=../lib ; ../tools/lib
Did not work; JVM could not find ///tools/lib ?

The iterations could take forever, so I aborted and just copied all files from tools/lib to
lib folder. 
The service started without any errors.  I have confirmed that there are no errors in any
logs.

I will keep looking for the wrapper.conf solution but I am not a Java programmer...not much
of a programmer at all...

I wish I could help you with the closing the issue, but I am just not familiar with the coding
or the systems...

> Running James as an NT service
> ------------------------------
>
>          Key: JAMES-460
>          URL: http://issues.apache.org/jira/browse/JAMES-460
>      Project: James
>         Type: Bug
>     Versions: 2.3.0
>  Environment: Windows 2000 Professional
> JDK1.5.0_04
>     Reporter: carlos aviles
>     Assignee: Stefano Bagnara

>
> When trying to launch the service (installed with the supplyed wrapper), the wrapper
throws an exception:
> STATUS | wrapper  | 2006/03/23 12:52:59 | Launching a JVM...
> INFO   | jvm 1    | 2006/03/23 12:52:59 | java.lang.NoClassDefFoundError: org/tanukisoftware/wrapper/WrapperListener

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message