james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fariza (JIRA)" <server-...@james.apache.org>
Subject [jira] Commented: (JAMES-775) Can't find resource
Date Mon, 05 Feb 2007 20:05:05 GMT

    [ https://issues.apache.org/jira/browse/JAMES-775?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12470337
] 

Fariza commented on JAMES-775:
------------------------------

I have verified that my jar file (where my mailet located) are in SAR-INF\lib directory with
the rest of the files.
FYI, I have run this mailet in James-2.2 for a year. What I am doing now is upgrading to James-2.3.0
and the only changes I made are in the config.xml file.

Back to my original question, I can see the 'error' to load properties files not only after
I put in the custom mailet. Using the original download file, I can see the same error. So
I don't think the custom mailet has anything to do with this.



> Can't find resource
> -------------------
>
>                 Key: JAMES-775
>                 URL: https://issues.apache.org/jira/browse/JAMES-775
>             Project: James
>          Issue Type: Bug
>    Affects Versions: 2.3.0
>         Environment: HP Unix, java 1.4, installation directory : /opt/james/phoenix-bin
>            Reporter: Fariza
>            Priority: Blocker
>
> I get the following 'INFO' message after installing James 2.3. This does not happen in
James 2.2.
> Even with this 'INFO' the James server runs. The problem is I have a customized mailet
that require me to load a properties file during startup. When I started james with the customized
mailet, it gave me the same error that it cannot find resource bundle and because of that
if failed to load the mailet.
> ---------ERROR------------------------------
> INFO    2007-02-05 10:04:36.174 [Phoenix.] (): Unknown resource. Bundle: 'org.apache.avalon.phoenix.components.monitor.Resources'
Key: 'scanner.skipping-file.notice' Args: '/opt/james/phoenix-bin/apps/james' Reason: java.util.MissingResourceException:
Can't find resource for bundle java.util.PropertyResourceBundle, key scanner.skipping-file.notice
> INFO    2007-02-05 10:04:36.669 [Phoenix.] (): Verifying that all key-stores have valid
names.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message