james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Noel J. Bergman" <n...@devtech.com>
Subject RE: Required version of Ant
Date Sun, 11 Mar 2007 21:49:51 GMT
Robert Burrell Donkin wrote:

> Noel J. Bergman wrote:

> > If someone wants to upgrade us to [JUnit] v4
> > (q.v. http://www.devx.com/Java/Article/31983),
> > feel free.  Please test before committing.
> >
> > I'm fairly convinced that we can move to JDK 5 for trunk,
> > since it will be a long time before we're ready to release
> > from it, and we can take advantage of new features, some
> > of which we really want to leverage.

> JAMES has mature java 1.4 implementations for several protocols.
> i've been wondering whether we might be able to use the
> modularisation to maintain support for 1.4 whilst exploiting 1.5
> features. so, rather than just jumping everything to 1.5, this
> choice could be made on a per module basis.

That's been the plan, but I'm wondering if we might not be better of just
going for JSE 5.  I do not expect to see anything releasable from trunk
until end of 2007, and that should be fine for JSE 5 and later.

For example, this would allow us to use annotations to help with assembly,
and that would be a pervasive change.

	--- Noel



---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message