james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "robert burrell donkin" <robertburrelldon...@gmail.com>
Subject Re: Required version of Ant
Date Sun, 11 Mar 2007 21:12:52 GMT
On 3/11/07, Noel J. Bergman <noel@devtech.com> wrote:
> Robert Burrell Donkin wrote:
>
> > [junit's license is] on the proposed list of approved binary licenses
> > (http://www.apache.org/legal/3party.html) so it should be fine. feel
> > free to add it.
>
> Done.  The version committed is 3.8.2.  If someone wants to upgrade us to v4
> (q.v. http://www.devx.com/Java/Article/31983), feel free.  Please test
> before committing.
>
> I'm fairly convinced that we can move to JDK 5 for trunk, since it will be a
> long time before we're ready to release from it, and we can take advantage
> of new features, some of which we really want to leverage.

JAMES has mature java 1.4 implementations for several protocols. i've
been wondering whether we might be able to use the modularisation to
maintain support for 1.4 whilst exploiting 1.5 features. so, rather
than just jumping everything to 1.5, this choice could be made on a
per module basis.

users could then use the configuration to switch between basic 1.4 and
advanced 1.5 versions.

- robert

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message