james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefano Bagnara <apa...@bago.org>
Subject Re: [mailbox] mailboxmanager -> mailbox?
Date Wed, 06 Jun 2007 17:24:52 GMT
robert burrell donkin ha scritto:
> IMHO the naming of mailboxmanager is inconsistent with it's contents
> and with the naming strategy adopted with mailboxrepository. i would
> prefer to change it to mailbox.
> 
> opinions?

Maybe I don't remember the code very well, but I don't think this is
appropriate.

When I looked at the code many months ago I thought about renaming
MailboxSession to Mailbox and not MailboxManager to Mailbox.

I think MailboxManager provide the methods to create, delete, get
instances of real Mailboxes, so it is not a mailbox itself. I think
renaming it to Mailbox would be misleading.

IMO MailboxManager is more like the current "Store" component and
MailboxSession is more like the current MailRepository if you're looking
for similarities.

Stefano


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message