james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kev Jackson (JIRA)" <server-...@james.apache.org>
Subject [jira] Created: (JAMES-833) ToMultiRepository doesn't resolve repository_name correctly
Date Mon, 14 Jan 2008 02:33:34 GMT
ToMultiRepository doesn't resolve repository_name correctly
-----------------------------------------------------------

                 Key: JAMES-833
                 URL: https://issues.apache.org/jira/browse/JAMES-833
             Project: James
          Issue Type: Bug
          Components: Matchers/Mailets (bundled)
    Affects Versions: Trunk
         Environment: all
            Reporter: Kev Jackson
             Fix For: Trunk


When using ToMultiRepository we noticed that it didn't store mails correctly - after turning
on debugging for the mailstore log we saw items like:

10/01/08 03:59:02 DEBUG mailstore: Parsed URL: table = 'spamstomcat@test.intranet.freelance.com',
repositoryName = 'null'

This is because, although ToMultiRepository is supposed to just take the local part of the
address for the repository name, it doesn't.
There's also a problem caused by the current code not checking if the repositoryUrl value
has a trailing '/' or not.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message