james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Markus Wiederkehr (JIRA)" <server-...@james.apache.org>
Subject [jira] Commented: (MIME4J-85) Upgrade source to Java 5
Date Thu, 13 Nov 2008 13:11:44 GMT

    [ https://issues.apache.org/jira/browse/MIME4J-85?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12647280#action_12647280
] 

Markus Wiederkehr commented on MIME4J-85:
-----------------------------------------

Thanks you very much! With the added dependency the translation of enums works like a charm.

I also tried to include the runtime classes in my jar using the "embed" parameter. But it
looks like all runtime classes are copied no matter if they are needed or not..

Is it possible to embed only the runtime classes that are actually required? The Retrotranslator
documentation speaks of a "partial copy"..

> Upgrade source to Java 5
> ------------------------
>
>                 Key: MIME4J-85
>                 URL: https://issues.apache.org/jira/browse/MIME4J-85
>             Project: JAMES Mime4j
>          Issue Type: Improvement
>    Affects Versions: 0.5
>            Reporter: Markus Wiederkehr
>             Fix For: 0.6
>
>         Attachments: mime4j-java5-v2.patch, mime4j-java5.patch
>
>
> The Mime4j API would greatly benefit from Java 5 language features, most of all Generics.
> For backward compatibility with JVM 1.4 the generated jar file could be transformed using
the Retrotranslator Maven Plugin. If this compatibility is required new features of the Java
5 API (such as StringBuilder) cannot be used.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message