james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bernd Fondermann" <bernd.fonderm...@googlemail.com>
Subject Re: [server] Java 5, Spring And Phoenix
Date Sun, 02 Nov 2008 21:11:54 GMT
On Sun, Nov 2, 2008 at 12:43, Stefano Bagnara <apache@bago.org> wrote:
> Robert Burrell Donkin ha scritto:
>> i'm increasingly convinced that the 3.0 codebase contains some
>> compelling reasons to upgrade. i think it's important to offer an
>> upgrade path for existing installations including retaining 1.4 JVM
>> support. this means preserving 1.4 compatibility in the API and
>> library layers and in any functions that existing in james 2.
>> i quite fancy experimenting with some stuff (for example OpenJPA) that
>> requires java 5. IIRC there are already some optional modules which
>> require a 1.5 JVM but i'd like to use a more regular system. i propose
>> using module names to allow java5 in the function layer. for example,
>> openjpa-java5 would act like openjpa-function but would only be
>> compiled when a 1.5 JVM is used.
>> any objections?
>> going forward, this will result in the issue that - given the current
>> build - new features would only be available atfer downloading the
>> source and compiling with a 1.5 JVM. i would like to suggest the
>> following long term strategy: we use the same module system but ship
>> the phoenix built under 1.4 (without new features) and spring built
>> under 1.5 (with the new features).
>> opinions?
> IMHO this is an useless waste of time :-)
> Let's drop Java 2 1.4 and declare java 5 as a requisite.
> Java 1.4 completed the EOL period 3 days ago: no one should seriusly use
> java 2 1.4 in any internet exposed machine.
> Unless we plan to include james in an applet or some old embedded device
> (and I never read about this scenario in this lists) java 1.4
> compatibility is useless.
> Java 5 runtime already provides "an upgrade path for existing
> installations" by smoothly running java 2 v1.4 code. This is true
> expecially if you think that JAMES is run in its own virtual machine and
> is not a component to be run inside old application servers.
> Once we'll have a working java5 release *if* many users will ask for a
> java 1.4 solution they can help us figuring it out using
> retroweaver/translator.

For a major release, upgrading the required Java version is ok.


To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org

View raw message