james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Markus Wiederkehr" <markus.wiederk...@gmail.com>
Subject Re: [mime4j] Retrotranslator for Java 5
Date Wed, 12 Nov 2008 22:52:50 GMT
On Wed, Nov 12, 2008 at 11:37 PM, Oleg Kalnichevski <olegk@apache.org> wrote:
> Do we care about 1.4 compatibility at all give the results of the poll? What
> is the reason for maintaining a 1.4 compatible version?

Personally I don't care about 1.4 and I don't believe many users will, too.

On the other hand the new patch I just attached to MIME4J-85 gives us
Java 1.4 compatibility at a very low price. The only compromise is
that o.a.j.m.m.Mode is no longer a true Java 5 enum. But the good old
typesafe enum pattern behaves very much the same.

I believe that now we have a Java 5 source code and a Java 1.4
compatible jar not much can stand in the way of applying this patch.

Markus

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message