james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefano Bagnara <apa...@bago.org>
Subject Re: Crypto mailets on James Snapshot 3
Date Tue, 13 Jan 2009 19:16:24 GMT
Robert Burrell Donkin ha scritto:
> On Tue, Jan 13, 2009 at 5:17 PM, Julio D'Angelo <jcdangelo@gmail.com> wrote:
>> Thanks for your answer, I managed to build a release of crypto mailets to
>> run with james 3.0 using jdk 1.5 (to enable pkcs11 support), now i'm having
>> this error:
>> ...
>> java.io.IOException: parseAlgParameters failed: PBE AlgorithmParameters not
>> available
>> at
>> com.sun.net.ssl.internal.ssl.PKCS12KeyStore.parseAlgParameters(PKCS12KeyStore.java:525)
>> at
>> com.sun.net.ssl.internal.ssl.PKCS12KeyStore.engineLoad(PKCS12KeyStore.java:1265)
>> at java.security.KeyStore.load(KeyStore.java:1150)
>> at
>> org.apache.james.mailet.crypto.SMIMEKeyHolder.<init>(SMIMEKeyHolder.java:131)
>> ...
>>
>> I think this is related to bouncycastle jce provider 1.5.
> 
> the stack trace contains "com.sun.net.ssl.internal.ssl"
> 
>> Is crypto mailets code compatible with java 1.5 and BC 1.5 provider ?
> 
> i haven't run this combination i'm not sure. i suspect that you may
> need to compile against BC 1.5 (and then maybe some fiddling is
> sometimes required) but i'd need some time to check everything so
> maybe you'll get there before me. if so, the i'd be great if you could
> contribute a patch back.

Maybe the appropriate bcprov from the bouncycastle website have to be
installed in james/lib AND/OR in the jre/lib/ext folder ? I don't
remember anymore but I think I'm using that mailets (well, not the same
mailets, but similar stuff) under java5 (and java6 too) and they works.

Stefano

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message