james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Markus Wiederkehr" <markus.wiederk...@gmail.com>
Subject [mime4j] Reconsider Message#getSubject()
Date Sun, 04 Jan 2009 18:49:38 GMT
I've noticed that Message has a method getSubject() that returns the
subject as UnstructuredField.

In my opinion it would be more practical if getSubject() simply
returned a string. The existing getSubject() method would not
necessarily have to go; it could also be renamed in getSubjectField()
or something like that.

Would that be too radical a change?

Furthermore I think that Message should have more convenience methods
like that, getDate(), getFrom(), getTo(), etc..

Of course setters would be nice too, setSubject(String),
setDate(Date), and so on..


To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org

View raw message