james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manuel Carrasco Moñino <manuel.carrasc...@gmail.com>
Subject Re: [HUPA]Re: Hupa build issue
Date Fri, 30 Oct 2009 09:04:20 GMT
Hello Mohan,

Does it happens when maven is running the tests?.

On Thu, Oct 29, 2009 at 6:51 PM, mohan chinnappan <mchinnappan@gmail.com> wrote:
> Dear Norman,
>
> Thanks for the quick reply.
>
> Yes, I use Windows ( I will check this on my Linux box later). The command
> that I used: clean package.
>
> You are correct. I  also think it is Windows-specific problem. We need to
> use OS independent path separators.
>
> Do you want me look and fix this problem? Please let me know.
>
> With Best Regards,
> Mohan
>
> On Thu, Oct 29, 2009 at 1:46 PM, Norman Maurer <norman@apache.org> wrote:
>
>>  Hi Mohan,
>>
>> the project compiles without a problem here.
>>
>> What mvn command did you run ? Using "mvn clean package" works without
>> problems here (I'm on a mac so maybe its related to windows).
>>
>> Thx,
>> Norman
>>
>> Ps: I send the message to server-dev too, because thats the
>> mailinglist used for hupa.
>>
>> 2009/10/29 mohan chinnappan <mchinnappan@gmail.com>:
>> > Dear Norman Maurer,
>> >
>> > Greetings!
>> >
>> > I just checked Hupa code from SVN and when I complied today with Maven
>> > build, I get the following error:
>> >
>> > -------
>> > ...
>> > at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> >     at
>> >
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> >     at
>> >
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>> >     at java.lang.reflect.Method.invoke(Method.java:597)
>> >     at
>> >
>> org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:345)
>> >     at
>> >
>> org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:1009)
>> > java.io.FileNotFoundException:
>> > C:\Users\mohan\workspace\hupa\server\war\WEB-INF\classes\mime%5c3.msg
>> (The
>> > system cannot find the file specified)
>> >     at java.io.FileInputStream.open(Native Method)
>> > ....
>> >
>> > --
>> > Here is the list of msg files under my eclipse's workspace:
>> >
>> > mohan@mohan-PC ~/workspace/hupa
>> > $ find . -name *msg -print
>> > ./client/war/WEB-INF/classes/mime/0.msg
>> > ./client/war/WEB-INF/classes/mime/1.msg
>> > ./client/war/WEB-INF/classes/mime/2.msg
>> > ./client/war/WEB-INF/classes/mime/3.msg
>> > ./client/war/WEB-INF/classes/mime/4.msg
>> > ./client/war/WEB-INF/classes/mime/5.msg
>> > ./client/war/WEB-INF/classes/mime/6.msg
>> > ./client/war/WEB-INF/classes/mime/7.msg
>> > ./server/src/main/resources/mime/0.msg
>> > ./server/src/main/resources/mime/1.msg
>> > ./server/src/main/resources/mime/2.msg
>> > ./server/src/main/resources/mime/3.msg
>> > ./server/src/main/resources/mime/4.msg
>> > ./server/src/main/resources/mime/5.msg
>> > ./server/src/main/resources/mime/6.msg
>> > ./server/src/main/resources/mime/7.msg
>> > ./server/war/WEB-INF/classes/mime/0.msg
>> > ./server/war/WEB-INF/classes/mime/1.msg
>> > ./server/war/WEB-INF/classes/mime/2.msg
>> > ./server/war/WEB-INF/classes/mime/3.msg
>> > ./server/war/WEB-INF/classes/mime/4.msg
>> > ./server/war/WEB-INF/classes/mime/5.msg
>> > ./server/war/WEB-INF/classes/mime/6.msg
>> > ./server/war/WEB-INF/classes/mime/7.msg
>> >
>> > Looks like mime file path is mangled. Any input is appreciated.
>> >
>> > Also, I like to contribute  to Hupa development, please let me know how.
>> >
>> >
>> > Regards,
>> > Mohan
>> >
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message