james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From limincn <limi...@hotmail.com>
Subject Re: How to configure the Websphere Business Event with apache-james
Date Mon, 16 Nov 2009 02:57:37 GMT

Hello

I used the following way you mentioned below and found that neithor the
abc@cn.ibm.com nor <abc@ibm.com>, the result passed to the James was
abc@cn.ibm.com without "<>".

Do you know how to configue the James to make James can parse the mail
Address without "<>".

For example abc@cn.ibm.com.


Stefano Bagnara-2 wrote:
> 
> 2009/11/13 limincn <limincn@hotmail.com>:
>>
>> No, I am sure I have not use "****".
>>
>> I have tried the following mail address.
>>
>> 1. abc@cn.ibm.com
>> 2. <abc@cn.ibm.com>
>> 3. "ABC" <abc@cn.ibm.com>
>> 4. "abc@cn.ibm.com"
>>
>> all of them are wrong. the error log is same.
>>
>> but according to the Websphere Business Event Help the 1 and 3 above
>> should
>> be right.
>>
>> If you think my answer is not suficient, could you tell me dou you think
>> which type of mail address will be right.
> 
> THe first address is correct, but you probably are looking to the wrong
> stuff.
> The problem is in the parameter that Websphere is passing to the "MAIL
> FROM:" command.
> There is a syntax error in the MAIL FROM command.
> If you are not able to determine what Websphere is passing in this
> command you can enable debug logging for the smtpserver in james:
> 
> <jamesfolder>/apps/james/SAR-INF/environment.xml:
> ---
>       <category name="smtpserver" log-level="DEBUG">
>         <log-target id-ref="smtpserver-target"/>
>       </category>
> ---
> Just change the log-level to DEBUG.
> 
> Then restart and look at
> <jamesfolder>/apps/james/logs/smtpserver-YYYY-MM*.log
> 
> Stefano
> 
> PS: as I told you before the right list is server-dev. So I reply
> there and to you. Let's stop using general@j.a.o for something it's
> not about. Subscribe to server-dev if you want answers.
> 
>> Stefano Bagnara-2 wrote:
>>>
>>>> but when I want to use apache-james in the Websphere Business Event,
>>>> the
>>>> mail can not be sent normally neither using ****@cn.ibm.com or using
>>>> <****@cn.ibm.com>.
>>>>
>>>> error log is:
>>>> Mail reply: (****@cn.ibm.com) 501 5.1.7 Syntax error in MAIL command
>>>
>>> The error say you have a syntax error in the email address.
>>> You obfuscated the email with "****" so it's hard to say if it was a
>>> correct address or not.
>>> But note that the syntax error is not in the recipient address, but
>>> the sender address (MAIL is the command used to send the FROM: email).
>>>
>>> Stefano
>>>
>>> PS: use server-user@j.a.o list for this kind of questions.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> For additional commands, e-mail: server-dev-help@james.apache.org
> 
> 
> 

-- 
View this message in context: http://old.nabble.com/Re%3A-How-to-configure-the-Websphere-Business-Event-with-apache-james-tp26333801p26366212.html
Sent from the James - Dev mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message