james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Neil Crow (JIRA)" <j...@apache.org>
Subject [jira] Created: (HUPA-63) Maven build is broken for gwt 2.0.0
Date Thu, 28 Jan 2010 11:53:36 GMT
Maven build is broken for gwt 2.0.0
-----------------------------------

                 Key: HUPA-63
                 URL: https://issues.apache.org/jira/browse/HUPA-63
             Project: JAMES Hupa
          Issue Type: Bug
         Environment: Windows XP,
Eclipse
Java 6
GWT 2.0.0
            Reporter: Neil Crow
            Assignee: Norman Maurer


I tried to build hupa from trunk last night, and failed several times with a dependency resolution
error.

Firstly, my local  version metadata for the gwt-maven-plugin was out of date, so I deleted
it and reran.

But again I got a dependency resolution error for com.google.gwt:gwt-dev:2.0.0.
The problem is that it was looking for the artifact with the windows classifier, and as of
gwt 2.0.0 the OS specific classifiers are no longer needed.

In order to compile for gwt-2.0.0, you need to use gwt-maven-plugin-1.2,
however client/pom.xml specifies version gwt-maven-plugin-1.1

Removing the version number from the plugin definition, or changing it to 1.2 will solve the
problem.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message