james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Avdhesh Yadav <...@avdheshyadav.com>
Subject Re: [hupa] How to run?
Date Fri, 19 Feb 2010 15:30:54 GMT
Already done it but no success...It works fine when i run from eclipse using
gwt plugin...

On Fri, Feb 19, 2010 at 8:38 PM, Bernd Fondermann <
bernd.fondermann@googlemail.com> wrote:

> On Fri, Feb 19, 2010 at 14:39, Avdhesh Yadav <avd@avdheshyadav.com> wrote:
> > But its not working for me :(
>
> Mine is larger than 10 MB, so I guess your build is broken.
> Please try a fresh checkout and see where you'll get from there.
>
>  Bernd
>
> >
> > On Fri, Feb 19, 2010 at 2:52 PM, Bernd Fondermann <
> > bernd.fondermann@googlemail.com> wrote:
> >
> >> On Fri, Feb 19, 2010 at 07:49, Avdhesh Yadav <avd@avdheshyadav.com>
> wrote:
> >> > I am building hupa from ../hupa_trunk path
> >> > command : *mvn clean package*
> >> >
> >> > hupa built in the path hupa/client/target. and then copy pasting the
> >> > hupa.war to tomcat/webapps folder.
> >> >
> >> > Is it right way to build and running hupa..?
> >>
> >> Yep, that's what I did.
> >>
> >>  Bernd
> >>
> >> > On Fri, Feb 19, 2010 at 12:11 PM, Avdhesh Yadav <avd@avdheshyadav.com
> >> >wrote:
> >> >
> >> >> Using FF 3.0.17..
> >> >>
> >> >> firbug Error : 404 not-found Get hupa.nocache.js..i think the
> compiled
> >> >> javascript part is missing from the war..
> >> >>
> >> >> Size of hupa.war 8.4 mb
> >> >>
> >> >> Maven version: 2.0.9
> >> >> Java version: 1.6.0_17
> >> >> OS name: "linux" version: "2.6.24-27-generic" arch: "i386" Family:
> >> "unix"
> >> >>
> >> >>
> >> >>
> >> >> On Fri, Feb 19, 2010 at 11:51 AM, Manuel Carrasco MoƱino <
> >> >> manolo@apache.org> wrote:
> >> >>
> >> >>> Which browser are you using?. Try to use FF + Firebug and check
if
> >> >>> there are errors.
> >> >>>
> >> >>> On Fri, Feb 19, 2010 at 5:48 AM, Avdhesh Yadav <
> avd@avdheshyadav.com>
> >> >>> wrote:
> >> >>> > Not working for me when i deploy hupa.war on tomcat.I can
not see
> the
> >> >>> login
> >> >>> > page..I can see the revolving hupa image only..
> >> >>> >
> >> >>> > It works fine when i run from eclipse..and i can login to
 my
> gmail
> >> >>> > account..
> >> >>> >
> >> >>> > here is my catalina.log
> >> >>> >
> >> >>> > Feb 19, 2010 10:11:03 AM
> >> org.apache.catalina.core.AprLifecycleListener
> >> >>> init
> >> >>> > INFO: The APR based Apache Tomcat Native library which allows
> optimal
> >> >>> > performance in production environments was not found on the
> >> >>> > java.library.path:
> >> >>> >
> >> >>>
> >>
> /usr/lib/jvm/java-6-sun-1.6.0.17/jre/lib/i386/client:/usr/lib/jvm/java-6-sun-1.6.0.17/jre/lib/i386:/usr/lib/jvm/java-6-sun-1.6.0.17/jre/../lib/i386:/usr/java/packages/lib/i386:/lib:/usr/lib
> >> >>> > Feb 19, 2010 10:11:03 AM org.apache.coyote.http11.Http11Protocol
> init
> >> >>> > INFO: Initializing Coyote HTTP/1.1 on http-8080
> >> >>> > Feb 19, 2010 10:11:03 AM org.apache.catalina.startup.Catalina
load
> >> >>> > INFO: Initialization processed in 462 ms
> >> >>> > Feb 19, 2010 10:11:04 AM org.apache.catalina.core.StandardService
> >> start
> >> >>> > INFO: Starting service Catalina
> >> >>> > Feb 19, 2010 10:11:04 AM org.apache.catalina.core.StandardEngine
> >> start
> >> >>> > INFO: Starting Servlet Engine: Apache Tomcat/6.0.20
> >> >>> > Feb 19, 2010 10:11:04 AM org.apache.catalina.startup.HostConfig
> >> >>> deployWAR
> >> >>> > INFO: Deploying web application archive hupa.war
> >> >>> > DEBUG: setDebug: JavaMail version 1.4.1ea-SNAPSHOT
> >> >>> > 1    [main] DEBUG gwtupload.server.UploadServlet  - UPLOAD-SERVLET
> >> init:
> >> >>> > maxSize=10485760, slowUploads=null, isAppEngine=false
> >> >>> > Feb 19, 2010 10:11:05 AM org.apache.coyote.http11.Http11Protocol
> >> start
> >> >>> > INFO: Starting Coyote HTTP/1.1 on http-8080
> >> >>> > Feb 19, 2010 10:11:06 AM org.apache.jk.common.ChannelSocket
init
> >> >>> > INFO: JK: ajp13 listening on /0.0.0.0:8009
> >> >>> > Feb 19, 2010 10:11:06 AM org.apache.jk.server.JkMain start
> >> >>> > INFO: Jk running ID=0 time=0/35  config=null
> >> >>> > Feb 19, 2010 10:11:06 AM org.apache.catalina.startup.Catalina
> start
> >> >>> > INFO: Server startup in 2063 ms
> >> >>> >
> >> >>> >
> >> >>> > Regards,
> >> >>> > Avdhesh
> >> >>> >
> >> >>> > On Thu, Feb 18, 2010 at 10:24 PM, Norman Maurer <
> >> >>> > norman.maurer@googlemail.com> wrote:
> >> >>> >
> >> >>> >> Hi Eric,
> >> >>> >>
> >> >>> >> maven 2.x is fine..
> >> >>> >>
> >> >>> >> Bye,
> >> >>> >> Norman
> >> >>> >>
> >> >>> >> 2010/2/18 Eric MacAdie <eric@macadie.net>:
> >> >>> >> > What version of Maven should be used?
> >> >>> >> >
> >> >>> >> > Eric MacAdie
> >> >>> >> >
> >> >>> >> > Norman Maurer wrote:
> >> >>> >> >>
> >> >>> >> >> HI Bernd,
> >> >>> >> >>
> >> >>> >> >> for testing:
> >> >>> >> >>
> >> >>> >> >> mvn gwt:run
> >> >>> >> >>
> >> >>> >> >> for real world usage:
> >> >>> >> >>
> >> >>> >> >> mvn package
> >> >>> >> >>
> >> >>> >> >> to generate the war and then deploy to tomcat
or an other
> servlet
> >> >>> >> >> container.
> >> >>> >> >>
> >> >>> >> >> Bye,
> >> >>> >> >> Norman
> >> >>> >> >>
> >> >>> >> >> 2010/2/18 Bernd Fondermann <bernd.fondermann@googlemail.com>:
> >> >>> >> >>
> >> >>> >> >>>
> >> >>> >> >>> Hi,
> >> >>> >> >>>
> >> >>> >> >>> how do I run hupa stand-alone as a web application?
> >> >>> >> >>>
> >> >>> >> >>> I managed to build it, using mvn install.
> >> >>> >> >>>
> >> >>> >> >>> What's next?
> >> >>> >> >>>
> >> >>> >> >>> For the record, I don't want to use Eclipse
nor some GWT
> >> Simulator.
> >> >>> >> >>>
> >> >>> >> >>> Has this already been done?
> >> >>> >> >>>
> >> >>> >> >>> Thanks,
> >> >>> >> >>>
> >> >>> >> >>>  Bernd
> >> >>> >> >>>
> >> >>> >> >>>
> >> >>> >> >>
> >> >>> >> >>
> >> >>> >> >>
> >> >>> >> >
> >> >>> >> >
> >> >>> >> >
> >> ---------------------------------------------------------------------
> >> >>> >> > To unsubscribe, e-mail:
> server-dev-unsubscribe@james.apache.org
> >> >>> >> > For additional commands, e-mail:
> server-dev-help@james.apache.org
> >> >>> >> >
> >> >>> >> >
> >> >>> >>
> >> >>> >>
> >> ---------------------------------------------------------------------
> >> >>> >> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> >> >>> >> For additional commands, e-mail:
> server-dev-help@james.apache.org
> >> >>> >>
> >> >>> >>
> >> >>> >
> >> >>>
> >> >>>
> ---------------------------------------------------------------------
> >> >>> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> >> >>> For additional commands, e-mail: server-dev-help@james.apache.org
> >> >>>
> >> >>>
> >> >
> >> >
> >> > --
> >> > Avdhesh Yadav
> >> > http://www.avdheshyadav.com
> >> >
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> >> For additional commands, e-mail: server-dev-help@james.apache.org
> >>
> >>
> >
> >
> > --
> > Avdhesh Yadav
> > http://www.avdheshyadav.com
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> For additional commands, e-mail: server-dev-help@james.apache.org
>
>


-- 
Avdhesh Yadav
http://www.avdheshyadav.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message