james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Charles <eric.char...@u-mangate.com>
Subject Re: How to run and debug hupa-client from Eclipse?
Date Fri, 22 Jul 2011 07:50:58 GMT
On 21/07/11 00:00, sonia wrote:
> Hello,
>
> I'm new to all this -- checking out public project, and trying to run them.
> I've used mvn eclipse:eclipse to import the projects into eclipse,
> since M2E did not recognize hupa-client as a web project and was
> annoying.
>

Last time I imported hupa in eclipse was long time ago.
If this does not work, there must be some tricks on the module 
definition. Don't hesitate to hack the poms and submit a patch if you 
find a solution.

> How can I debug it?
> I can deploy the war into tomcat and run it, but cant run (nor debug)
> anything when I try to deploy hupa-client project from within eclipse,
> to the same tomcat instance.
>

For other GWT projects, I used a main class that launched a Jetty web 
container. I also had to use special WebAppClassLoader (or such) to make 
the container automatically reload in case of src code change. Once 
again, patch welcome :)

Thx for testing Hupa!

(sent to server-dev rather than sit-dev)

> What did you do to make it work for you? What am I missing?
>
> Thanks,
> sonia


-- 
Eric Charles
http://about.echarles.net

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message