james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Norman Maurer <norman.mau...@googlemail.com>
Subject Re: Prepare for new mailbox release
Date Tue, 04 Oct 2011 10:44:34 GMT
Yeah please add it back as without it its not buildable. I wonder if
we may not just use "normal" hadoop for the tests as we don't care
about append or not in tests.

wdyt ?

Bye,
Norman


2011/10/4 Felix Knecht <felixk@apache.org>:
> Just adding the repository does works for me using the current trunk (I
> think I should commit it to make it compiling also when having a clean local
> repository...). But there may be another problem we can run into: There's no
> garantee, that the rawson's repository will stay when have done the release.
> It does also works using the hadoop-test-0.20.3-SNAPSHOT, but this will not
> solve the problem, because the release procedure will not perform when
> having SNAPSHOT dependencies included.
>
>  <repositories>
>    <repository>
>      <id>hadoop-non-releases</id>
>      <name>Hadoop non-releases</name>
>      <url>http://people.apache.org/~rawson/repo/</url>
>      <snapshots>
>        <enabled>false</enabled>
>      </snapshots>
>      <releases>
>        <enabled>true</enabled>
>      </releases>
>    </repository>
>  </repositories>
>
> Regards
> Felix
>
> PS
> I run it on a linux box. If ever Windows boxes may behave different because
> of file locking ...
>
> On 09/30/2011 06:58 PM, Ioan Eugen Stan wrote:
>>>
>>>  From what I can remember, there are some issues with [1]
>>> https://issues.apache.org/jira/browse/MAILBOX-133. It's abut the
>>> tests, which require a running HBase cluster. I will try to fix it
>>> tomorrow.
>>>
>>> I think I can fix this by creating a special testing configuration for
>>> HBase mailbox (using spring testing framework and
>>> @ContextConfiguration ) in which I start a MiniHBase cluster.
>>>
>>> But this is kind of weird, that testing integration requires something
>>> like this.
>>
>> I tried to fix the issue without much success. I manage to create the
>> cluster but the test seems to hang and does nothing.
>> I attached the patch so you can follow my modifications. Things are
>> going quite slow because I lost some stuff, including my glasses.
>>
>> Does the test require some information in HBase, like a table schema?
>>
>> Regards,
>>
>>
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
>> For additional commands, e-mail: server-dev-help@james.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> For additional commands, e-mail: server-dev-help@james.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message