james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ioan Eugen Stan <stan.ieu...@gmail.com>
Subject problems upgrading data-hbase to HBase 0.92
Date Fri, 09 Mar 2012 15:32:06 GMT
Hello,

I've started upgrading James components to use hbase 0.92 and hadop
1.0.1. I've moved mailbox and mailbox-integration-testing
successfully. However, I have encountered some problems with upgrading
data-hbase module from james-server. The tests fail because of some
issues with the minicluster (region not found exception or something
like that).

Eric could you please investigate this? I think the issue is related
to the way the MiniCluster is started/stopped and would be happy to
take care of this issue by using the HBase test classes I created for
HBase mailbox and integrate them here.

Since we need to share the test infrastructure and maybe some other
stuff between James components that require HBase/ Hadoop I wish to
propose developing a common module where we could store this kind of
stuff. I think this is useful since HBase/ Hadoop tooling is not yet
as mature as other technologies such as databases.

WDYT?

Regards,

-- 
Ioan Eugen Stan
http://ieugen.blogspot.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message