james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Charles <e...@apache.org>
Subject Re: ClassNotFoundException on Custom Mailet
Date Tue, 24 Jul 2012 11:51:19 GMT
Hi,

We had a bug on jar loading and on documentation.
You don't have to specify mailetpackage and you have to use the full 
class name.

The jar in conf/lib will only work with latest snapshots.

Thx, Eric

On 07/24/2012 12:47 PM, Merve Temizer wrote:
> Lines from my mailetcontainer.xml
>
>
> <mailetcontainer enableJmx="true">
>
> <mailetpackages>
>        <mailetpackage>kobu.omikuji.Omikuji</mailetpackage>
> <mailetpackage>org.apache.james.transport.mailets</mailetpackage>
>      <mailetpackage>org.apache.james.transport.mailets.smime</mailetpackage>
>      </mailetpackages>
>
> ....
>
> <processor state="transport" enableJmx="true">
> ...
>        <mailet match="RecipientIs=omikuji@localhost"
>   class="kobu.omikuji.Omikuji" >
>              <jinja>omikuji@localhost</jinja>
>        </mailet>
> ...
> </processor>
>
> ...
> </mailetcontainer>
>
>
> i added Omukuji.class into a jar and import it into james/conf/lib
>
> i tried many other configuration like
>
> <mailetpackage>kobu.omikuji</mailetpackage>
>
>   <mailet match="RecipientIs=omikuji@localhost"  class="Omikuji" >
>
> than it says "i could not found org.apache.james.transport.mailets.Omukuji"
>
> thanks for any suggestion
>


-- 
eric | http://about.echarles.net | @echarles


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message