james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From echo <echo...@gmail.com>
Subject Re: Seems we can not use the patched ResolverServiceLayer
Date Tue, 17 Jul 2012 08:46:34 GMT
Hi all
With the great help of Manolo, issues are solved finally. Some important
notes here:
It is better to link projects when changing things in different modules in
Eclipse. For Hupa Evo's case:

   - The parent project is not so necessary that we can delete it without
   deleting the project contents on disk(or just close the project).
   - Then, edit the classpath of hupa(client project), add the other
   projects in the *Projects* tab(hupa->properties->Java Build
   Path->Projects).
   - In the *Order and Export* tab, make the order look like follow(there
   may be nothing in []), and then clean all projects(Projects->clean->Select
   All):

hupa/src/main/java
hupa/src/main/resources
hupa/src/test/java
[Persisted container]
hupa/target/generated-sources/apt
Maven Dependencies
JRE
hupa-mock
hupa-server
hupa-shared
hupa-widgets



   - If you had any RF error after changing any RF class maybe you need to
   re-run the RF validator,normally Eclipse does, but some times it is
   necesary to force the validation.
   - When changing RF or GIN it is recomendable to restart the dev-mode


On Tue, Jul 17, 2012 at 3:20 PM, Manuel Carrasco Moñino
<manolo@apache.org>wrote:

> I've checked in your code and It works smoothly in my eclipse. I'm using
> Juno + plugins (google, m2e, etc) in an Ubuntu.
> I think you have a problem with your classpath.
>
> BTW The patch to gwt has been reviewed and I's pending to be accepted in
> the trunk, it's well tested with edge cases, so I think it should not being
> causing any issue
>
> - Manolo
>
>
> On Tue, Jul 17, 2012 at 9:09 AM, Manuel Carrasco Moñino <manolo@apache.org
> > wrote:
>
>> It's weird, the patched file works in a project I have in production,
>> I'll check your code so as I can figure out what's happening.
>> I'm using gwt-2.5.0-rc1 instead of 2.4.0 but there are no so much changes
>> in the RF stuff.
>>
>> - Manolo
>>
>>
>> On Mon, Jul 16, 2012 at 5:43 PM, echo <echowdx@gmail.com> wrote:
>>
>>> P.S.
>>> After the exception, I want to undo the changes to see whether they will
>>> act like the origin status(work better). Unfortunately, they won't.
>>> I was totally lost and confused.
>>>
>>>
>>> On Mon, Jul 16, 2012 at 11:23 PM, echo <echowdx@gmail.com> wrote:
>>>
>>>> Hi manolo
>>>> I've try to use the patched file, but I always go wrong:
>>>> I use ArchLinux or Win7, and the Eclipse version is Indigo, Hupa Evo is
>>>> r43. At the beginning, both of them work better. But after I change
>>>> someting(change the server.service.ImapFolderService to
>>>> ImapFolderServiceImpl, move share.proxy.ImapFolder to
>>>> share.domain.ImapFolder), they will say the exception I
>>>> referred(ImapFolderImpl cannot be sent to client).
>>>>
>>>> I searched the methods how can I use ResolverServiceLayer before
>>>> gwt-user.jar, but there seemed be nothing can be referred.
>>>>
>>>> What's I really don't know is why they worked well at the beginning
>>>> rather after something was changed. Will they invoke
>>>> our ResolverServiceLayer at the beginning, yet the gwt's after changing
>>>> something?
>>>>
>>>> --
>>>> *echo*
>>>>
>>>
>>>
>>>
>>> --
>>> *echo*
>>>
>>
>>
>


-- 
*echo*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message