james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Merve Temizer <mervet2...@gmail.com>
Subject Re: Custom Mailet: Getting MimeMessage of Mail
Date Fri, 12 Oct 2012 09:09:56 GMT
I sent mail through Thunderbird,

i saw in debug environment my mailet has run, look at the variable at
breakpoint in Eclipse, org.apache.mailet.Mail.getmessage().getcontent is
still null.

Thanks for advice.

2012/10/11 Merve Temizer <mervet2009@gmail.com>

> i am going to try with mail client and send you feed back.
> thanks for attention
>
>
> 2012/10/11 Merve Temizer <mervet2009@gmail.com>
>
>> I am sending mail with
>>
>>
>> $telnet localhost 1025(1025 is port that i set to james)
>>
>> mail from:<user2@localhost>
>> rcpt to:<user2@localhost>
>>
>> data
>> mycontent
>> .
>>
>> i can see mail and its content in folder that i specified for mail
>> recording.
>>
>> 1025 because i changed it, it is not the pr
>>
>>
>> 2012/10/11 Eric Charles <eric.charles@u-mangate.com>
>>
>>> Is the content null if you send via regular mail client?
>>>
>>> Which telnet commands do you issue?
>>>
>>> Thx, Eric
>>>
>>>
>>>
>>> On 10/10/2012 16:58, Merve Temizer wrote:
>>>
>>>> Hello,
>>>>
>>>> I have a custom mailet, i see it runs on debug environment.
>>>>
>>>> in service(org.apache.mailet.Mail mail)
>>>>
>>>> mail.getMessage().getContent is null.
>>>>
>>>> I am sending a mail using telnet smtp connection.
>>>>
>>>> I think i am doing sth wrong, can you advice sth to specify the problem.
>>>>
>>>> Thanks.
>>>>
>>>>
>>> --
>>> @echarles
>>>
>>> ------------------------------**------------------------------**
>>> ---------
>>> To unsubscribe, e-mail: server-dev-unsubscribe@james.**apache.org<server-dev-unsubscribe@james.apache.org>
>>> For additional commands, e-mail: server-dev-help@james.apache.**org<server-dev-help@james.apache.org>
>>>
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message