james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Echo <echo...@gmail.com>
Subject Re: [jira] [Updated] (HUPA-106) many dependency upgrades, GWT 2.5.0, jetty 8.1.7
Date Wed, 30 Jan 2013 04:51:06 GMT
Thanks Mark,
I have upgraded Hupa Evolution[1] GWT dependency to the latest 2.5.0, and
the other libs should also be updated as well.
I must say sorry to our community about the Evolution's development's
progress, because I have not begun to make a new theme based on roundcube's
larry skin until recently even though the idea has been around the corner
for a long time. The login page has been completed currently[2] and the
main layout practice is under coding[3]. I hope to establish the new mail
theme as soon as possible and then fix the corresponding bugs exposed,
since my new career after graduating from institute seems familiar with me.
Manolo, could you give me some suggestions about the Hupa Evo's future. I
have no idea on whether/how/when we should merge it to the main branch.
>From the product point of view, we should do this after the Hupa Evo is
stable enough without any fetal bugs. however I hope merge it as soon as
possible so that I can report the progress every commit and might get more
aid and feedback from our community. What's your opinion?
As the larry skin from roundcube, I will ensure complying with their
"excluded skins and plugins" GPLv3 license.

Thanks. <3


[1]
http://code.google.com/a/apache-extras.org/p/hupa-evo/source/detail?r=120
[2]
http://code.google.com/a/apache-extras.org/p/hupa-evo/issues/detail?id=20
[3]
http://code.google.com/a/apache-extras.org/p/hupa-evo/source/detail?r=125



On Wed, Jan 30, 2013 at 6:57 AM, Mark (JIRA) <jira@apache.org> wrote:

>
>      [
> https://issues.apache.org/jira/browse/HUPA-106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel]
>
> Mark updated HUPA-106:
> ----------------------
>
>     Description:
> Please apply the attached patch.
>
>
> Patch written against -r 1440125
> https://svn.apache.org/repos/asf/james/hupa/trunk
>
>
>
>
>
> Patch details (from my personal SVN repo):
>
>
> ------------------------------------------------------------------------
> r4476 | mark | 2013-01-29 23:46:55 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> update dependencies: easymock 3.1, commons-io 2.4, gwtupload 0.6.6,
> javax.mail 1.4.5, log4j 1.2.17; add maven 3.0 requirement
>
> ------------------------------------------------------------------------
> r4475 | mark | 2013-01-29 23:17:06 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> update dependency: gin 2.0.0
>
> ------------------------------------------------------------------------
> r4474 | mark | 2013-01-29 23:02:09 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> added maven and gwt notes to README
>
> ------------------------------------------------------------------------
> r4473 | mark | 2013-01-29 22:57:17 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> fix gwt-dev dependency warning
>
> ------------------------------------------------------------------------
> r4472 | mark | 2013-01-29 22:45:12 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> fix README: maven demo profile hint was missing
>
> ------------------------------------------------------------------------
> r4471 | mark | 2013-01-29 22:34:32 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> * minor README fix and upgrade to Jetty 8.1.7.v20120910 and servlet spec
> 3.0.1
>
> ------------------------------------------------------------------------
> r4470 | mark | 2013-01-29 22:10:16 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> update dependency versions to: gwt-2.5.0, junit-4.11
>
> ------------------------------------------------------------------------
> r4469 | mark | 2013-01-29 22:04:08 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> add maven-enforcer-plugin to force sane versions
>
> ------------------------------------------------------------------------
> r4468 | mark | 2013-01-29 21:59:59 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> svn export -r 1440125 https://svn.apache.org/repos/asf/james/hupa/trunkhupa
>
> ------------------------------------------------------------------------
>
>
>   was:
> Patch written against -r 1440125
> https://svn.apache.org/repos/asf/james/hupa/trunk
>
>
>
>
>
> Patch details (from my personal SVN repo):
>
>
> ------------------------------------------------------------------------
> r4476 | mark | 2013-01-29 23:46:55 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> update dependencies: easymock 3.1, commons-io 2.4, gwtupload 0.6.6,
> javax.mail 1.4.5, log4j 1.2.17; add maven 3.0 requirement
>
> ------------------------------------------------------------------------
> r4475 | mark | 2013-01-29 23:17:06 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> update dependency: gin 2.0.0
>
> ------------------------------------------------------------------------
> r4474 | mark | 2013-01-29 23:02:09 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> added maven and gwt notes to README
>
> ------------------------------------------------------------------------
> r4473 | mark | 2013-01-29 22:57:17 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> fix gwt-dev dependency warning
>
> ------------------------------------------------------------------------
> r4472 | mark | 2013-01-29 22:45:12 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> fix README: maven demo profile hint was missing
>
> ------------------------------------------------------------------------
> r4471 | mark | 2013-01-29 22:34:32 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> * minor README fix and upgrade to Jetty 8.1.7.v20120910 and servlet spec
> 3.0.1
>
> ------------------------------------------------------------------------
> r4470 | mark | 2013-01-29 22:10:16 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> update dependency versions to: gwt-2.5.0, junit-4.11
>
> ------------------------------------------------------------------------
> r4469 | mark | 2013-01-29 22:04:08 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> add maven-enforcer-plugin to force sane versions
>
> ------------------------------------------------------------------------
> r4468 | mark | 2013-01-29 21:59:59 +0100 (Di, 29. Jan 2013) | 2 Zeilen
>
> svn export -r 1440125 https://svn.apache.org/repos/asf/james/hupa/trunkhupa
>
> ------------------------------------------------------------------------
>
>
>
> > many dependency upgrades, GWT 2.5.0, jetty 8.1.7
> > ------------------------------------------------
> >
> >                 Key: HUPA-106
> >                 URL: https://issues.apache.org/jira/browse/HUPA-106
> >             Project: James Hupa
> >          Issue Type: Dependency upgrade
> >          Components: client, server
> >            Reporter: Mark
> >            Assignee: Manuel Carrasco MoƱino
> >            Priority: Trivial
> >         Attachments: patch
> >
> >
> > Please apply the attached patch.
> > Patch written against -r 1440125
> https://svn.apache.org/repos/asf/james/hupa/trunk
> > Patch details (from my personal SVN repo):
> > ------------------------------------------------------------------------
> > r4476 | mark | 2013-01-29 23:46:55 +0100 (Di, 29. Jan 2013) | 2 Zeilen
> > update dependencies: easymock 3.1, commons-io 2.4, gwtupload 0.6.6,
> javax.mail 1.4.5, log4j 1.2.17; add maven 3.0 requirement
> > ------------------------------------------------------------------------
> > r4475 | mark | 2013-01-29 23:17:06 +0100 (Di, 29. Jan 2013) | 2 Zeilen
> > update dependency: gin 2.0.0
> > ------------------------------------------------------------------------
> > r4474 | mark | 2013-01-29 23:02:09 +0100 (Di, 29. Jan 2013) | 2 Zeilen
> > added maven and gwt notes to README
> > ------------------------------------------------------------------------
> > r4473 | mark | 2013-01-29 22:57:17 +0100 (Di, 29. Jan 2013) | 2 Zeilen
> > fix gwt-dev dependency warning
> > ------------------------------------------------------------------------
> > r4472 | mark | 2013-01-29 22:45:12 +0100 (Di, 29. Jan 2013) | 2 Zeilen
> > fix README: maven demo profile hint was missing
> > ------------------------------------------------------------------------
> > r4471 | mark | 2013-01-29 22:34:32 +0100 (Di, 29. Jan 2013) | 2 Zeilen
> > * minor README fix and upgrade to Jetty 8.1.7.v20120910 and servlet spec
> 3.0.1
> > ------------------------------------------------------------------------
> > r4470 | mark | 2013-01-29 22:10:16 +0100 (Di, 29. Jan 2013) | 2 Zeilen
> > update dependency versions to: gwt-2.5.0, junit-4.11
> > ------------------------------------------------------------------------
> > r4469 | mark | 2013-01-29 22:04:08 +0100 (Di, 29. Jan 2013) | 2 Zeilen
> > add maven-enforcer-plugin to force sane versions
> > ------------------------------------------------------------------------
> > r4468 | mark | 2013-01-29 21:59:59 +0100 (Di, 29. Jan 2013) | 2 Zeilen
> > svn export -r 1440125 https://svn.apache.org/repos/asf/james/hupa/trunkhupa
> > ------------------------------------------------------------------------
>
> --
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA
> administrators
> For more information on JIRA, see: http://www.atlassian.com/software/jira
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> For additional commands, e-mail: server-dev-help@james.apache.org
>
>


-- 
*echo*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message