james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emma Sesmero <emmasesm...@gmail.com>
Subject Re: Problem running James
Date Thu, 13 Jun 2013 09:00:39 GMT
The wrapper.log was a file with the output.

Anyways, with Java6 it works!
Thank you very much.


2013/6/13 Manuel Carrasco Moñino <manolo@apache.org>

> Actually you have not attached the output.
>
> Could you install sun java6 (I use this version) instead of java7
>
> On Thu, Jun 13, 2013 at 10:20 AM, Emma Sesmero <emmasesmero@gmail.com>
> wrote:
> > I do not think there is anything running in the port 25
> >
> > root@emma-K55A:/home/emma/apache-james-3.0-beta4/bin# telnet localhost
> 25
> > Trying 127.0.0.1...
> > telnet: Unable to connect to remote host: Connection refused
> >
> >
> > But there is a problem running the wrapper. I get an
> > IllegalAnnotationException. I have attached the output.
> >
> >
> >
> > 2013/6/13 Manuel Carrasco Moñino <manolo@apache.org>
> >>
> >> - can you run the launcher without daemonizing james? run this as root
> >> from the bin folder
> >>  # ./wrapper-linux-x86-32  ../conf/wrapper.conf
> >>
> >> - maybe you have running other mail server in the port 25? try:
> >>  # telnet localhost 25
> >>
> >> On Thu, Jun 13, 2013 at 9:38 AM, Emma Sesmero <emmasesmero@gmail.com>
> >> wrote:
> >> > My java version is 1.7
> >> >
> >> > emma@emma-K55A:~$ java -version
> >> > java version "1.7.0_21"
> >> > Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
> >> > Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)
> >> >
> >> >
> >> >
> >> > 2013/6/13 Manuel Carrasco Moñino <manolo@apache.org>
> >> >
> >> >> Your output is ok, which version of java have you installed? Run java
> >> >> -version
> >> >> On Jun 12, 2013 12:09 AM, "Emma Sesmero" <emmasesmero@gmail.com>
> wrote:
> >> >>
> >> >> > Hi Manolo,
> >> >> >
> >> >> > I have run what you said, and this is the output I obtained:
> >> >> >
> >> >> > emma@emma-K55A:~/apache-james-3.0-beta4/bin$ ldd
> >> >> > /home/emma/apache-james-3.0-beta4/bin/./wrapper-linux-x86-32
> >> >> > linux-gate.so.1 =>  (0xf7727000)
> >> >> > libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf76f2000)
> >> >> > libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7549000)
> >> >> > /lib/ld-linux.so.2 (0xf7728000)
> >> >> >
> >> >> >
> >> >> > Is anything missing?
> >> >> >
> >> >> >
> >> >> > 2013/6/11 Manuel Carrasco Moñino <manolo@apache.org>
> >> >> >
> >> >> > > Emma, try to execute this:
> >> >> > >
> >> >> > > # bash -x james start
> >> >> > >
> >> >> > > The last line is the final command the script runs, copy
the
> >> >> > > executable execute the ldd command to know whether you have
the
> >> >> > > necessary .so libs.
> >> >> > > In may case:
> >> >> > >
> >> >> > > # ldd
> >> >> > > /msoft/james/apache-james-3.0-beta4/bin/./wrapper-linux-x86-32
> >> >> > > linux-gate.so.1 =>  (0xf77dc000)
> >> >> > > libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0
> (0xf779a000)
> >> >> > > libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf75e7000)
> >> >> > > /lib/ld-linux.so.2 (0xf77dd000)
> >> >> > >
> >> >> > > maybe you don't have a valid libc.so.6
> >> >> > >
> >> >> > >
> >> >> > > - Manolo
> >> >> > >
> >> >> > > On Tue, Jun 11, 2013 at 8:46 PM, Emma Sesmero
> >> >> > > <emmasesmero@gmail.com>
> >> >> > > wrote:
> >> >> > > > Hi,
> >> >> > > >
> >> >> > > > I need help running James. I am working on ubuntu 12.04
and I
> >> >> > > > think I
> >> >> > > have
> >> >> > > > followed the steps in the documentation:
> >> >> > > >
> >> >> > > > 1) I have downloaded the binary code.
> >> >> > > > 2) I have unzip it.
> >> >> > > > 3) I have get into the bin folder, became root and run
the
> >> >> > > > following:
> >> >> > > >
> >> >> > > > root@emma-K55A:/home/emma/apache-james-3.0-beta4/bin#
./james
> >> >> > > > start
> >> >> > > > Starting Apache James Server App...
> >> >> > > > root@emma-K55A:/home/emma/apache-james-3.0-beta4/bin#
ps
> -feaww |
> >> >> grep
> >> >> > > james
> >> >> > > > root     11086 10998  0 13:05 pts/3    00:00:00 grep
> --color=auto
> >> >> james
> >> >> > > >
> >> >> > > >
> >> >> > > > It does not give me any errors, but it is not running.
> >> >> > > > I have checked the logs and all of them are empty but
> >> >> james-server.log
> >> >> > > that
> >> >> > > > shows this:
> >> >> > > >
> >> >> > > >
> >> >> > > > INFO  12:32:54,420 |
> >> >> > > >
> >> >> >
> >> >> >
> org.apache.james.container.spring.context.JamesServerApplicationContext |
> >> >> > > > Refreshing
> >> >> > > >
> >> >> > >
> >> >> >
> >> >>
> >> >>
> org.apache.james.container.spring.context.JamesServerApplicationContext@611353a7
> >> >> > > :
> >> >> > > > startup date [Tue Jun 11 12:32:54 CEST 2013]; root of
context
> >> >> hierarchy
> >> >> > > > INFO  12:56:42,758 |
> >> >> > > >
> >> >> >
> >> >> >
> org.apache.james.container.spring.context.JamesServerApplicationContext |
> >> >> > > > Refreshing
> >> >> > > >
> >> >> > >
> >> >> >
> >> >>
> >> >>
> org.apache.james.container.spring.context.JamesServerApplicationContext@3bd92abb
> >> >> > > :
> >> >> > > > startup date [Tue Jun 11 12:56:42 CEST 2013]; root of
context
> >> >> hierarchy
> >> >> > > > INFO  13:04:58,488 |
> >> >> > > >
> >> >> >
> >> >> >
> org.apache.james.container.spring.context.JamesServerApplicationContext |
> >> >> > > > Refreshing
> >> >> > > >
> >> >> > >
> >> >> >
> >> >>
> >> >>
> org.apache.james.container.spring.context.JamesServerApplicationContext@3bd92abb
> >> >> > > :
> >> >> > > > startup date [Tue Jun 11 13:04:58 CEST 2013]; root of
context
> >> >> hierarchy
> >> >> > > > INFO  13:16:36,938 |
> >> >> > > >
> >> >> >
> >> >> >
> org.apache.james.container.spring.context.JamesServerApplicationContext |
> >> >> > > > Refreshing
> >> >> > > >
> >> >> > >
> >> >> >
> >> >>
> >> >>
> org.apache.james.container.spring.context.JamesServerApplicationContext@3bd92abb
> >> >> > > :
> >> >> > > > startup date [Tue Jun 11 13:16:36 CEST 2013]; root of
context
> >> >> hierarchy
> >> >> > > > INFO  13:16:41,630 |
> >> >> > > >
> >> >> >
> >> >> >
> org.apache.james.container.spring.context.JamesServerApplicationContext |
> >> >> > > > Refreshing
> >> >> > > >
> >> >> > >
> >> >> >
> >> >>
> >> >>
> org.apache.james.container.spring.context.JamesServerApplicationContext@611353a7
> >> >> > > :
> >> >> > > > startup date [Tue Jun 11 13:16:41 CEST 2013]; root of
context
> >> >> hierarchy
> >> >> > > >
> >> >> > > > I have not changed the default configuration, is that
the
> reason?
> >> >> > > > Do
> >> >> I
> >> >> > > need
> >> >> > > > to edit any configuration file to be able to run the
server?
> >> >> > > >
> >> >> > > > Thanks in advance.
> >> >> > >
> >> >> > >
> >> >> > >
> ---------------------------------------------------------------------
> >> >> > > To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> >> >> > > For additional commands, e-mail:
> server-dev-help@james.apache.org
> >> >> > >
> >> >> > >
> >> >> >
> >> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> >> For additional commands, e-mail: server-dev-help@james.apache.org
> >>
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> > For additional commands, e-mail: server-dev-help@james.apache.org
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> For additional commands, e-mail: server-dev-help@james.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message