james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sasa Milenkovic (JIRA)" <server-...@james.apache.org>
Subject [jira] [Created] (JAMES-1509) SSL/TLS IMAP doesn't work with MS Outlook
Date Wed, 05 Jun 2013 18:42:21 GMT
Sasa Milenkovic created JAMES-1509:
--------------------------------------

             Summary: SSL/TLS IMAP doesn't work with MS Outlook
                 Key: JAMES-1509
                 URL: https://issues.apache.org/jira/browse/JAMES-1509
             Project: James Server
          Issue Type: Bug
          Components: IMAPServer
         Environment: james-server-app-3.0.0-beta5-20130531.150929-105-app
            Reporter: Sasa Milenkovic
            Priority: Critical


Hi, 

this is my first post here. 
I am having problems with reading IMAP messages from MS Outlook (i.e. 2010), while T-Bird
and other clients works as expected.  This problem is occurring just when i add self-signed
cert. When I am using unsecured communication, everything works fine, but I need SSl/TLS on
MS Outlook 2003/2007/2010 

On the server side I have Linux Debian, and minimum of two additional machines (DNS and Win7
with MS Outlook) in the local network, so I can only have self-signed certificate (no public
domain). SMTP is not secured and present on 2525 port just for compatibility, root processor
is empty as I do not need sending messages. 

However, Outlook accepts certificate and tests connection without complaining I even got folder
structure and mail list, but when I try to read any mail Outlook does something and puff -
connection goes to hell . One version of Outlook even crash. James shows this trace in imapserver.log:

... 
INFO  12:54:10,103 | james.imapserver | ID=1705397097 Connection established from 192.168.1.102

DEBUG 12:54:11,704 | james.imapserver | ID=1705397097 Got <tag>: 3kyy 
DEBUG 12:54:11,705 | james.imapserver | ID=1705397097 Got <command>: CAPABILITY 
DEBUG 12:54:11,730 | james.imapserver | ID=1705397097 No mailbox selected 
DEBUG 12:54:11,977 | james.imapserver | ID=1705397097 Got <tag>: vity 
DEBUG 12:54:11,978 | james.imapserver | ID=1705397097 Got <command>: LOGIN 
DEBUG 12:54:12,106 | james.imapserver | ID=1705397097 INBOX exists. No need to create it.

DEBUG 12:54:12,327 | james.imapserver | ID=1705397097 Got <tag>: rmbb 
DEBUG 12:54:12,329 | james.imapserver | ID=1705397097 Got <command>: IDLE 
DEBUG 12:54:12,342 | james.imapserver | ID=1705397097 No mailbox selected 
DEBUG 12:54:12,715 | james.imapserver | ID=1705397097 Got <tag>: aovf 
DEBUG 12:54:12,716 | james.imapserver | ID=1705397097 Got <command>: LIST 
DEBUG 12:54:12,940 | james.imapserver | ID=1705397097 Got <tag>: ased 
DEBUG 12:54:12,941 | james.imapserver | ID=1705397097 Got <command>: IDLE 
DEBUG 12:54:12,944 | james.imapserver | ID=1705397097 No mailbox selected 
DEBUG 12:54:16,572 | james.imapserver | ID=1705397097 Got <tag>: 8jcl 
DEBUG 12:54:16,573 | james.imapserver | ID=1705397097 Got <command>: LIST 
DEBUG 12:54:28,019 | james.imapserver | ID=1705397097 Got <tag>: i0zm 
DEBUG 12:54:28,020 | james.imapserver | ID=1705397097 Got <command>: LSUB 
DEBUG 12:54:28,406 | james.imapserver | ID=1705397097 Got <tag>: sqa1 
DEBUG 12:54:28,407 | james.imapserver | ID=1705397097 Got <command>: SELECT 
DEBUG 12:54:28,410 | james.imapserver | ID=1705397097 Loaded mailbox #private:sasa1@jatheon.com:sasaTest

DEBUG 12:54:28,430 | james.imapserver | ID=1705397097 Loaded mailbox #private:sasa1@jatheon.com:sasaTest

DEBUG 12:54:32,319 | james.imapserver | ID=1705397097 Got <tag>: egrm 
DEBUG 12:54:32,319 | james.imapserver | ID=1705397097 Got <command>: FETCH 
DEBUG 12:54:32,327 | james.imapserver | ID=1705397097 Loaded mailbox #private:sasa1@jatheon.com:sasaTest

DEBUG 12:54:32,341 | james.imapserver | ID=1705397097 Loaded mailbox #private:sasa1@jatheon.com:sasaTest

DEBUG 12:54:32,525 | james.imapserver | ID=1705397097 Got <tag>: r9n5 
DEBUG 12:54:32,526 | james.imapserver | ID=1705397097 Got <command>: UID 
DEBUG 12:54:32,540 | james.imapserver | ID=1705397097 Loaded mailbox #private:sasa1@jatheon.com:sasaTest

DEBUG 12:54:32,564 | james.imapserver | ID=1705397097 Loaded mailbox #private:sasa1@jatheon.com:sasaTest

DEBUG 12:54:32,730 | james.imapserver | ID=1705397097 Got <tag>: 54vi 
DEBUG 12:54:32,731 | james.imapserver | ID=1705397097 Got <command>: UID 
DEBUG 12:54:32,733 | james.imapserver | ID=1705397097 Loaded mailbox #private:sasa1@jatheon.com:sasaTest

DEBUG 12:54:32,751 | james.imapserver | ID=1705397097 Loaded mailbox #private:sasa1@jatheon.com:sasaTest

WARN  12:54:37,596 | james.imapserver | ID=1705397097 Error while processing imap request:
java.io.IOException - Connection reset by peer 
DEBUG 12:54:37,601 | james.imapserver | ID=1705397097 Error while processing imap request

java.io.IOException: Connection reset by peer 
        at sun.nio.ch.FileDispatcher.read0(Native Method) 
        at sun.nio.ch.SocketDispatcher.read(SocketDispatcher.java:21) 
        at sun.nio.ch.IOUtil.readIntoNativeBuffer(IOUtil.java:198) 
        at sun.nio.ch.IOUtil.read(IOUtil.java:166) 
        at sun.nio.ch.SocketChannelImpl.read(SocketChannelImpl.java:245) 
        at org.jboss.netty.channel.socket.nio.NioWorker.read(NioWorker.java:315) 
        at org.jboss.netty.channel.socket.nio.NioWorker.processSelectedKeys(NioWorker.java:274)

        at org.jboss.netty.channel.socket.nio.NioWorker.run(NioWorker.java:194) 
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)

        at java.lang.Thread.run(Thread.java:662) 
IINFO  12:54:37,612 | james.imapserver | ID=1705397097 Connection closed for 192.168.1.102

INFO  12:55:05,217 | james.imapserver | ID=1634157420 Connection established from 192.168.1.102

DEBUG 12:55:05,682 | james.imapserver | ID=1634157420 Got <tag>: z464 
DEBUG 12:55:05,683 | james.imapserver | ID=1634157420 Got <command>: CAPABILITY 
DEBUG 12:55:05,688 | james.imapserver | ID=1634157420 No mailbox selected 
DEBUG 12:55:05,908 | james.imapserver | ID=1634157420 Got <tag>: q3s4 
... 

config: 
imapserver.xml: set for socketTLS on port 993, 
james-database.property: set for MySQL db, 
james.keystore: RSA 2048 key 
mailbox.xml: set for maildir 
mailetcontainer.xml: everything under root processor commented out 
pop3server.xml: turned off (everything deleted under popo3server tag except jmxName) 
smtpserver.xml: default on 2525 port 
  
I am generating mails myself and putting them into maildirs, that part is working properly
as if other clients have no complaints, only Outlook doesn't work properly. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message