james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phillip Odam <phillip.o...@nitorgroup.com>
Subject Re: James 3.0-beta3 and jdk1.7
Date Wed, 18 Dec 2013 18:29:10 GMT
Hi Blanca

I haven't tried getting 3.0-beta3 up and running on java 1.7 but have 
run beta4 on 1.7 and I think I came across exactly this same issue.

Here's my notes, quite likely to be wrong for beta5 that's under 
development but may work for beta3. Note jaxb 2.1.15 no longer the latest.

To run Apache JAMES on Java 1.7 one adjustment is currently required as 
the beta release of Apache JAMES 3.0 does not work on Java 1.7. In 
Apache JAMES's conf/lib place the file jaxb-impl.jar from jaxb 2.1.x, 
most recent release found at http://jaxb.java.net/2.1.15/. Inside the 
downloaded zip file you will find the jar at jaxb-ri/lib/jaxb-impl.jar

On 12/18/13, 1:09 PM, Eric Charles wrote:
> Prolly latest jdk7 needs latest james.
>
> On 12/18/2013 11:12 AM, BlancaHN wrote:
>> Hi,
>>
>> I have just upgraded my java version, and currently I am using the latest
>> jdk so far (jdk1.7.0_45). I have the same problem as other users in this
>> forum:
>>
>> Caused by:
>> com.sun.xml.internal.bind.v2.runtime.IllegalAnnotationsException:
>> 1 counts of IllegalAnnotationExceptions
>> Class has two properties of the same name "outputs"
>>          this problem is related to the following location:
>>                  at public java.util.List
>> org.apache.camel.model.ResequenceDefinition.getOutputs()
>>                  at org.apache.camel.model.ResequenceDefinition
>>          this problem is related to the following location:
>>                  at private java.util.List
>> org.apache.camel.model.ResequenceDefinition.outputs
>>                  at org.apache.camel.model.ResequenceDefinition
>>
>> Any ideas? The solutions I read didn´t work for me (probably because
>> we are
>> still using the beta 3 version??).
>> Which james library does import the JAXB dependency? I couldn´t figure it
>> out, maybe the javaxb-api 2.2.11 version (the latest one) solves the
>> problem.
>>
>> Thanks
>>
>>
>>
>> --
>> View this message in context:
>> http://james.10919.n7.nabble.com/James-3-0-beta3-and-jdk1-7-tp51429.html
>> Sent from the James - Dev mailing list archive at Nabble.com.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
>> For additional commands, e-mail: server-dev-help@james.apache.org
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
> For additional commands, e-mail: server-dev-help@james.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message