james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bernd Waibel (JIRA)" <server-...@james.apache.org>
Subject [jira] [Commented] (JAMES-1563) Switch to Maven3
Date Fri, 31 Oct 2014 08:54:35 GMT

    [ https://issues.apache.org/jira/browse/JAMES-1563?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14191607#comment-14191607
] 

Bernd Waibel commented on JAMES-1563:
-------------------------------------

When building with Eclipse integrated Maven 3.2.1 you get the following error:
{noformat}
[ERROR] Metadata Type: org.apache.maven.artifact.repository.metadata.ArtifactRepositoryMetadata
could not be retrieved from repositories due to an error: repository metadata for: 'artifact
org.apache.james:james-server-spring' could not be retrieved from repository: central due
to an error: Error transferring file: http://repo.maven.apache.org/maven2/org/apache/james/james-server-spring/maven-metadata.xml
from http://repo.maven.apache.org/maven2/org/apache/james/james-server-spring/maven-metadata.xml
{noformat}
The reason is the out-dated structure, maybe.

Building with Maven 3.2.3 (external to eclipse) is ok, and does not produce an error.

> Switch to Maven3
> ----------------
>
>                 Key: JAMES-1563
>                 URL: https://issues.apache.org/jira/browse/JAMES-1563
>             Project: James Server
>          Issue Type: Improvement
>          Components: Build System
>    Affects Versions: Trunk, 3.0.0-beta5
>         Environment: Eclipse LUNA with integrated Mave 3.2.1 (m2eclipse)
> Together with Maven 3.2.3 
>            Reporter: Bernd Waibel
>            Priority: Minor
>             Fix For: 3.0.0-beta5
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> Building with old maven in actual eclipse is some kind outdated.
> It is easy possible to switch to maven 3, with the following changes:
> 1. Eclipse Luna with Maven 3.2.1 is ok for: mvn install, package, clean. Not for mvn
site.
> 2. Maven 3.2.3 is ok for mvn install, package, clean, site.
> The Maven 3.2.1 could not build the site, because the structure on "http://repo.maven.apache.org/maven2/"
is wrong. The structure is from 2012 and for Maven2, so maybe the structure need to get updated.
Nothing I can do.
> For switching to Maven3, which I did, you need to change the pom.xml. Details and patch
will follow.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message