james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Charles <e...@apache.org>
Subject Re: My custom mailbox won't show headers in Outlook
Date Sun, 01 Mar 2015 07:15:18 GMT
(late reply...) If JPA/Maildir... works with Outook, I guess there is
something to fix in your custom mailbox implementation.

On 12/01/2014 10:58 AM, Thomas Söhngen wrote:
> Hi James Community,
>
> I am working on a mailbox that connects to a custom store. That store
> has its own format to save email messages, so I can't just store the
> byte arrays there and had to write a parser to convert messages from
> and to the custom format of the store. The messages are parsed from
> and to Thunderbird without problems, but I have problems displaying
> the header information in Outlook. This is true even for mails that I
> saved to the mailbox via Outlook, and even if I take the exact header
> sent to James as a byte array, encode it as a Base64 string, save it
> to the store and decode it back directly to a byte array input stream
> when the message is retrieved (so never converting it to a String,
> avoiding charset issues), the header will still not be displayed in
> Outlook.
> Outlook seems to interpret the header in some way, because it finds
> the boundary and the mail body starts at the right position, but it
> doesn't show any header information.
> The JPA store i.e. doesn't seem to have this problem, is there any
> special trick I have to use to make the headers work in Outlook?
>
> Any suggestion would be very appreciated.
>
> Best regards,
> Thomas Söhngen
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message