james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tellier Benoit (JIRA)" <server-...@james.apache.org>
Subject [jira] [Commented] (JAMES-1563) Switch to Maven3
Date Fri, 24 Apr 2015 12:35:38 GMT

    [ https://issues.apache.org/jira/browse/JAMES-1563?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14510961#comment-14510961
] 

Tellier Benoit commented on JAMES-1563:
---------------------------------------

Hi,

We tested the build ( mvn clean install ) with the following version of maven :

3.0.1
3.0.4
3.0.5
3.1.0
3.1.1
3.2.1
3.2.2
3.2.3
3.2.5
3.3.1

I had troubbles with mvn site :

 - Error with maven-site-plugin 3.2 : Execution default-site of goal org.apache.maven.plugins:maven-site-plugin:3.2:site
failed: A required class was missing while executing org.apache.maven.plugins:maven-site-plugin:3.2:site:
org/sonatype/aether/graph/DependencyFilter

Upgrading to 3.4 solves the issue ( I made my modifications in james-project 1.8.2 ).

- Doclint is enabled by default with Java 8 , and generates error, that make the javadoc generation
fail.

Desactivating doclint validation by default solves the problem for now. See JAMES-1573 for
correcting this issue.

With these modifications I had 'maven clean site' working for all maven version listed above.

> Switch to Maven3
> ----------------
>
>                 Key: JAMES-1563
>                 URL: https://issues.apache.org/jira/browse/JAMES-1563
>             Project: James Server
>          Issue Type: Improvement
>          Components: Build System
>    Affects Versions: Trunk, 3.0.0-beta5
>         Environment: Eclipse LUNA with integrated Mave 3.2.1 (m2eclipse)
> Together with Maven 3.2.3 
>            Reporter: Bernd Waibel
>            Priority: Minor
>             Fix For: 3.0.0-beta5
>
>         Attachments: maven3.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> Building with old maven in actual eclipse is some kind outdated.
> It is easy possible to switch to maven 3, with the following changes:
> 1. Eclipse Luna with Maven 3.2.1 is ok for: mvn install, package, clean. Not for mvn
site.
> 2. Maven 3.2.3 is ok for mvn install, package, clean, site.
> The Maven 3.2.1 could not build the site, because the structure on "http://repo.maven.apache.org/maven2/"
is wrong. The structure is from 2012 and for Maven2, so maybe the structure need to get updated.
Nothing I can do.
> For switching to Maven3, which I did, you need to change the pom.xml. Details and patch
will follow.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message