james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tellier Benoit (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MAILBOX-11) MailboxQuery ignore namespace
Date Tue, 12 May 2015 08:02:01 GMT

     [ https://issues.apache.org/jira/browse/MAILBOX-11?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tellier Benoit updated MAILBOX-11:
----------------------------------
    Attachment: 0001-MAILBOX-11-Add-filters-on-namespace-and-user-for-sea.patch

In this patch, we added a check for user and namespace in the StoreMailboxManager::search
.

Tests are provided for that against the inMemoryMailboxManager

We then added corrections to the inMemoryMailboxMapper::findMailboxWithPathLike so that it
returns only results belonging to the appropriate namespace and user.

We also added tests for the inMemoryMailboxMapper::findMailboxWithPathLike .

Finnally, end to end testing for this issue is provided by MPT-13

> MailboxQuery ignore namespace
> -----------------------------
>
>                 Key: MAILBOX-11
>                 URL: https://issues.apache.org/jira/browse/MAILBOX-11
>             Project: James Mailbox
>          Issue Type: Bug
>         Environment: Linux, JDK 1.6
>            Reporter: Fran├žois-Denis Gonthier
>            Assignee: Norman Maurer
>             Fix For: 0.6
>
>         Attachments: 0001-MAILBOX-11-Add-filters-on-namespace-and-user-for-sea.patch
>
>
> MailboxQuery doesn't pay any attention to namespace of the mailbox it is based on. For
example, Mozilla Thunderbird might to mailbox search with expressions like #private.%. That
expression is passed directly to the isExpressionMatch method of the MailboxQuery class. This
has obviously incorrect results.
> Arguments to the isExpressionMatch method should be parsed to separate the namespace
from the mailbox name or isExpressionMatch should do the parsing itself. In that case the
argument name should be renamed to something like 'searchExpression' instead of 'name' which
doesn't convey the right meaning.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message