james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tellier Benoit (JIRA)" <server-...@james.apache.org>
Subject [jira] [Commented] (JAMES-1653) Some code is not Java 6 compliant
Date Mon, 11 Jan 2016 15:55:39 GMT

    [ https://issues.apache.org/jira/browse/JAMES-1653?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15092175#comment-15092175
] 

Tellier Benoit commented on JAMES-1653:
---------------------------------------

Having an in memory docker to speed compilation up, I can tell you we have broken DockerFile.

Nothing armful : 

 ---> Running in 14b67b276d98
Reading package lists...
Building dependency tree...
Reading state information...
Suggested packages:
  gettext-base git-daemon-run git-daemon-sysvinit git-doc git-el git-email
  git-gui gitk gitweb git-arch git-cvs git-mediawiki git-svn
Recommended packages:
  patch less rsync
The following packages will be DOWNGRADED:
  git
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 3 not upgraded.
Need to get 3624 kB of archives.
After this operation, 303 kB disk space will be freed.
E: There are problems and -y was used without --force-yes
The command '/bin/sh -c apt-get install -y git="$GIT_VERSION"' returned a non-zero code: 100

Seems like we need to add a --force-yes option...

I will propose a patch for this.

> Some code is not Java 6 compliant
> ---------------------------------
>
>                 Key: JAMES-1653
>                 URL: https://issues.apache.org/jira/browse/JAMES-1653
>             Project: James Server
>          Issue Type: Bug
>            Reporter: Raphaƫl Ouazana
>         Attachments: 0001-JAMES-1653-Fix-Java-6-errors-WIP.patch
>
>
> Java 6 errors some code:
> ChannelManageSieveResponseWriter.java	/james-server-protocols-managesieve/src/main/java/org/apache/james/managesieveserver/netty
line 39	Java Problem
> The import java.nio.charset.StandardCharsets cannot be resolved	ChannelManageSieveResponseWriter.java
/james-server-protocols-managesieve/src/main/java/org/apache/james/managesieveserver/netty
line 28	Java Problem
> The method close(Closeable, boolean) in the type Closeables is not applicable for the
arguments (Socket, boolean)	SpamAssassinInvoker.java	/james-server-util/src/main/java/org/apache/james/util/scanner
line 141	Java Problem
> The method closeQuietly(Reader) in the type IOUtils is not applicable for the arguments
(Scanner)	ManageSieveMailet.java	/james-server-mailets/src/main/java/org/apache/james/transport/mailets/managesieve
line 202	Java Problem



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message