james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Baechler (JIRA)" <server-...@james.apache.org>
Subject [jira] [Commented] (JAMES-2208) upgrade netty to netty-all
Date Fri, 10 Nov 2017 10:28:00 GMT

    [ https://issues.apache.org/jira/browse/JAMES-2208?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16247325#comment-16247325
] 

Matthieu Baechler commented on JAMES-2208:
------------------------------------------

Netty 4 is not API compatible with Netty 3 so we have to port James code, it's not just a
dependency update.

> upgrade netty to netty-all
> --------------------------
>
>                 Key: JAMES-2208
>                 URL: https://issues.apache.org/jira/browse/JAMES-2208
>             Project: James Server
>          Issue Type: Improvement
>          Components: James Core
>    Affects Versions: 3.0.0
>            Reporter: Randal Modowski
>
> James is currently using the netty dependency 
> <dependency>
>     <groupId>io.netty</groupId>
>     <artifactId>netty</artifactId>
>     <version>3.10.6.Final</version>
> </dependency>
> I think we should upgrade to the newer artifact
> <dependency>
>     <groupId>io.netty</groupId>
>     <artifactId>netty-all</artifactId>
>     <version>4.1.16.Final</version>
> </dependency>



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message