james-server-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From btell...@apache.org
Subject [james-project] 05/08: JAMES-2767 Downgrading ES startup check to v6.3.2
Date Wed, 05 Jun 2019 10:09:32 GMT
This is an automated email from the ASF dual-hosted git repository.

btellier pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/james-project.git

commit 1d52c54287a62354a978485b689d1822a687b074
Author: Rene Cordier <rcordier@linagora.com>
AuthorDate: Tue Jun 4 14:50:39 2019 +0700

    JAMES-2767 Downgrading ES startup check to v6.3.2
---
 .../org/apache/james/modules/mailbox/ElasticSearchStartUpCheck.java  | 5 ++---
 .../apache/james/JamesWithNonCompatibleElasticSearchServerTest.java  | 2 +-
 2 files changed, 3 insertions(+), 4 deletions(-)

diff --git a/server/container/guice/cassandra-guice/src/main/java/org/apache/james/modules/mailbox/ElasticSearchStartUpCheck.java
b/server/container/guice/cassandra-guice/src/main/java/org/apache/james/modules/mailbox/ElasticSearchStartUpCheck.java
index 3af12d9..e8eb258 100644
--- a/server/container/guice/cassandra-guice/src/main/java/org/apache/james/modules/mailbox/ElasticSearchStartUpCheck.java
+++ b/server/container/guice/cassandra-guice/src/main/java/org/apache/james/modules/mailbox/ElasticSearchStartUpCheck.java
@@ -26,7 +26,6 @@ import javax.inject.Inject;
 import org.apache.james.backends.es.ElasticSearchConfiguration;
 import org.apache.james.lifecycle.api.StartUpCheck;
 import org.elasticsearch.Version;
-import org.elasticsearch.client.RequestOptions;
 import org.elasticsearch.client.RestHighLevelClient;
 import org.slf4j.Logger;
 import org.slf4j.LoggerFactory;
@@ -35,7 +34,7 @@ public class ElasticSearchStartUpCheck implements StartUpCheck {
 
     private static final Logger LOGGER = LoggerFactory.getLogger(ElasticSearchConfiguration.class);
 
-    private static final Version RECOMMENDED_ES_VERSION = Version.fromString("6.7.2");
+    private static final Version RECOMMENDED_ES_VERSION = Version.fromString("6.3.2");
     private static final String VERSION_CHECKING_ERROR_MESSAGE = "Error when checking ES
version";
 
     public static final String CHECK_NAME = "ElasticSearchStartUpCheck";
@@ -50,7 +49,7 @@ public class ElasticSearchStartUpCheck implements StartUpCheck {
     @Override
     public CheckResult check() {
         try {
-            Version esVersion = client.info(RequestOptions.DEFAULT)
+            Version esVersion = client.info()
                 .getVersion();
             if (esVersion.isCompatible(RECOMMENDED_ES_VERSION)) {
                 return CheckResult.builder()
diff --git a/server/container/guice/cassandra-guice/src/test/java/org/apache/james/JamesWithNonCompatibleElasticSearchServerTest.java
b/server/container/guice/cassandra-guice/src/test/java/org/apache/james/JamesWithNonCompatibleElasticSearchServerTest.java
index 22830c3..3e16305 100644
--- a/server/container/guice/cassandra-guice/src/test/java/org/apache/james/JamesWithNonCompatibleElasticSearchServerTest.java
+++ b/server/container/guice/cassandra-guice/src/test/java/org/apache/james/JamesWithNonCompatibleElasticSearchServerTest.java
@@ -66,7 +66,7 @@ class JamesWithNonCompatibleElasticSearchServerTest {
                     .containsOnly(CheckResult.builder()
                         .checkName(ElasticSearchStartUpCheck.CHECK_NAME)
                         .resultType(StartUpCheck.ResultType.BAD)
-                        .description("ES version(2.4.6) is not compatible with the recommendation(6.7.2)")
+                        .description("ES version(2.4.6) is not compatible with the recommendation(6.3.2)")
                         .build()));
 
         assertThat(server.isStarted())


---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org


Mime
View raw message