jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-415) Guava 16 compatibility
Date Sat, 25 Jan 2014 19:02:37 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13881988#comment-13881988
] 

ASF subversion and git services commented on JCLOUDS-415:
---------------------------------------------------------

Commit c49489afc8d3e910067469bf62bc9f335db64825 in branch refs/heads/JCLOUDS-415 from [~andrewp]
[ https://git-wip-us.apache.org/repos/asf?p=jclouds.git;h=c49489a ]

JCLOUDS-415: Upgrading to Guava 16.0

Invokable.equals has changed from 15 to 16 so we need to implement the check differently ourselves.


> Guava 16 compatibility
> ----------------------
>
>                 Key: JCLOUDS-415
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-415
>             Project: jclouds
>          Issue Type: Improvement
>          Components: jclouds-core
>    Affects Versions: 1.7.0
>            Reporter: Andrew Gaul
>            Assignee: Andrew Gaul
>             Fix For: 1.7.1
>
>
> Guava 16 removes several deprecated APIs which makes using jclouds 1.7 with newer Guavas
fail.  More general issue than JCLOUDS-413.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message