jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Gaul (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-415) Guava 16 compatibility
Date Mon, 27 Jan 2014 18:35:57 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13883073#comment-13883073
] 

Andrew Gaul commented on JCLOUDS-415:
-------------------------------------

[~andrewp] We should apply the fix to jclouds 1.7.1 but not upgrade Guava.  Some users, including
me, use a newer Guava than what jclouds ships.  We should allow for this kind of use.

> Guava 16 compatibility
> ----------------------
>
>                 Key: JCLOUDS-415
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-415
>             Project: jclouds
>          Issue Type: Improvement
>          Components: jclouds-core
>    Affects Versions: 1.7.0
>            Reporter: Andrew Gaul
>            Assignee: Andrew Gaul
>
> Guava 16 removes several deprecated APIs which makes using jclouds 1.7 with newer Guavas
fail.  More general issue than JCLOUDS-413.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message