jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeremiah Robertson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-443) Cannot use rackspace-cloudservers-us or aws-ec2 as the provider
Date Mon, 10 Feb 2014 15:00:26 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-443?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13896630#comment-13896630
] 

Jeremiah Robertson commented on JCLOUDS-443:
--------------------------------------------

Sorry, I have another question. Does the BlobStoreContext take Openstack
credentials or can it take Rackspace Credentials? I get the following
error: java.lang.IllegalArgumentException: api {id=openstack-nova,
name=OpenStack Nova Diablo+ API,
views=[org.jclouds.compute.ComputeServiceContext], endpointName=identity
service url ending in /v2.0/, identityName=${userName},
credentialName=Optional.of(${apiKey}), documentation=
http://docs.rackspace.com/loadbalancers/api/v1.0/clb-devguide/content/index.html,
api=interface org.jclouds.openstack.nova.v2_0.NovaApi, asyncApi=interface
org.jclouds.openstack.nova.v2_0.NovaAsyncApi} not wrappable as
org.jclouds.blobstore.BlobStoreContext; context:
org.jclouds.rest.RestContext<org.jclouds.openstack.nova.v2_0.NovaApi,
org.jclouds.openstack.nova.v2_0.NovaAsyncApi>, views:
[org.jclouds.compute.ComputeServiceContext]

On the following piece of code:

BlobStoreContext context = ContextBuilder.newBuilder(providerin)
            .credentials(username, apiKey)
            .buildView(BlobStoreContext.class);






-- 
Jeremiah Robertson
Georgia Tech Junior
Aerospace Engineering
Grand Challenges Program
jrspfd@gmail.com
417.207.1563


> Cannot use rackspace-cloudservers-us or aws-ec2 as the provider
> ---------------------------------------------------------------
>
>                 Key: JCLOUDS-443
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-443
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-compute
>    Affects Versions: 1.7.0
>         Environment: Ubuntu 13.10, Eclipse
>            Reporter: Jeremiah Robertson
>            Priority: Minor
>              Labels: easyfix
>             Fix For: 1.7.0
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> When I go to create the ComputeServiceContext with my credentials and provider in the
rackspace example for creating a server or for the Logging example (CreateServer.java and
Logging.java), it never fully compiles it cannot find the provider. I used rackspace-cloudservers-us
and aws-ec2 as the 2 providers with their set of credentials, and neither worked. Are these
still supported? Please email me back at jrspfd@gmail.com if you have aby ideas on what might
be wrong because it worked a week ago and I'm not really sure whats going on. Thank you!



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message