jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ignasi Barrera (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-443) Cannot use rackspace-cloudservers-us or aws-ec2 as the provider
Date Sun, 02 Feb 2014 23:10:09 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-443?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13889103#comment-13889103
] 

Ignasi Barrera commented on JCLOUDS-443:
----------------------------------------

Sure. Have a read to the following links to understand what the classpath is and how it is
configured in Eclipse:

[What is a classpath|http://stackoverflow.com/questions/2396493/what-is-a-classpath-confused-and-need-a-human-touch-to-understand]
[Eclipse Java build path|http://help.eclipse.org/indigo/index.jsp?topic=%2Forg.eclipse.jdt.doc.user%2Freference%2Fref-properties-build-path.htm]

That will help you understand which kind of information I was asking about. Basically, I want
to make sure that all the jclouds JAR files you need are configured in the build path for
your project, as it seems that some is missing and that may be why your project does not compile.
Could you share your build path configuration?

> Cannot use rackspace-cloudservers-us or aws-ec2 as the provider
> ---------------------------------------------------------------
>
>                 Key: JCLOUDS-443
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-443
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-compute
>    Affects Versions: 1.7.0
>         Environment: Ubuntu 13.10, Eclipse
>            Reporter: Jeremiah Robertson
>            Priority: Minor
>              Labels: easyfix
>             Fix For: 1.7.0
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> When I go to create the ComputeServiceContext with my credentials and provider in the
rackspace example for creating a server or for the Logging example (CreateServer.java and
Logging.java), it never fully compiles it cannot find the provider. I used rackspace-cloudservers-us
and aws-ec2 as the 2 providers with their set of credentials, and neither worked. Are these
still supported? Please email me back at jrspfd@gmail.com if you have aby ideas on what might
be wrong because it worked a week ago and I'm not really sure whats going on. Thank you!



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message