jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-511) Incorrect feature definition: jclouds-rackspace-cloudblockstorage-uk/us
Date Mon, 31 Mar 2014 14:16:15 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-511?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13955201#comment-13955201
] 

ASF subversion and git services commented on JCLOUDS-511:
---------------------------------------------------------

Commit a7422966616abcad3c72cc78b521b07ee10d828b in jclouds-karaf's branch refs/heads/JCLOUDS-511-1.7.x
from [~gzres]
[ https://git-wip-us.apache.org/repos/asf?p=jclouds-karaf.git;h=a742296 ]

JCLOUDS-511: Correcting features with dependency-only bundles


> Incorrect feature definition: jclouds-rackspace-cloudblockstorage-uk/us
> -----------------------------------------------------------------------
>
>                 Key: JCLOUDS-511
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-511
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-karaf
>    Affects Versions: 1.7.1
>            Reporter: Grzegorz Grzybek
>            Assignee: Andrew Phillips
>             Fix For: 1.8.0
>
>         Attachments: JCLOUDS-511.patch
>
>
> For example, uk feature has the following definition:
> {code:xml}
> <feature name='jclouds-rackspace-cloudblockstorage-uk' description='Racksapce Cloud
Block Storage UK' version='${project.version}' resolver='(obr)'>
>   <feature version='${project.version}'>jclouds-api-openstack-cinder</feature>
>   <feature version='${project.version}'>jclouds-api-rackspace-cloudidentity</feature>
>   <bundle>mvn:org.apache.jclouds.provider/rackspace-cloudblockstorage-uk/${jclouds.version}</bundle>
> </feature>
> {code}
> and {{jclouds-api-rackspace-cloudidentity}}:
> {code:xml}
> <feature name="jclouds-api-rackspace-cloudidentity" description="Rackspace Cloud Identity
API" version="${project.version}" resolver="(obr)">
>   <feature version='${project.version}'>jclouds-compute</feature>
>   <feature version='${project.version}'>jclouds-api-openstack-keystone</feature>
>   <bundle dependency='true'>mvn:org.apache.jclouds.api/rackspace-cloudidentity/${jclouds.version}</bundle>
> </feature>
> {code}
> However, with current Karaf there's no way the bundle "mvn:org.apache.jclouds.api/rackspace-cloudidentity/${jclouds.version}"
will get installed. Bundles with {dependency="true"} are taken into account only during resolution
of other bundles from the same feature - not of the _upper_ feature which uses other features.
In other words - {{<bundle dependency="true" />}} doesn't _bubble up_.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message