jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shri Javadekar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-645) Incorrect endpoint url chosen for default region of HPCloud Object Storage
Date Fri, 01 Aug 2014 01:05:38 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-645?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14081773#comment-14081773
] 

Shri Javadekar commented on JCLOUDS-645:
----------------------------------------

One difference that I find between jclouds 1.7.x and jclouds 1.8.0 is that when LocationIdToURIFromAccessForTypeAndVersion.get()
is invoked, in jclouds 1.7.0, the apiVersion is set to "1.0" whereas in jclouds 1.8.0, the
apiVersion is null. In the service catalog returned by HPCloud the version  for region-a is
"1.0", region-b is "1". That explains why region-a is selected in jclouds-1.7.x.

The problem now is to identify why jclouds-1.8.0 does not have the version set to "1.0".

> Incorrect endpoint url chosen for default region of HPCloud Object Storage
> --------------------------------------------------------------------------
>
>                 Key: JCLOUDS-645
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-645
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-blobstore
>    Affects Versions: 1.8.0
>            Reporter: Shri Javadekar
>            Assignee: Chris Custine
>             Fix For: 1.8.0
>
>
> JClouds seems to be choosing the wrong endpoint from the service catalog returned by
HPCloud Object Storage.
> From what I see there are two endpoints returned in the Object Storage part of the service
catalog.
> D 07-31 13:21:22.122 pool-1-thread-1 jclouds.wire:59 |::] << "          "publicURL":
"https:\/\/region-a.geo-1.objects.hpcloudsvc.com\/v1\/53176293441764",[\n]"
> D 07-31 13:21:22.124 pool-1-thread-1 jclouds.wire:59 |::] << "          "publicURL":
"https:\/\/region-b.geo-1.objects.hpcloudsvc.com\/v1\/53176293441764",[\n]"
> I do not have any region configured.
> With 1.7.3, the first url was getting used and my tests were succeeding. However, with
1.8.0 the second url get's chosen and my tests failed with a "404 Not Found" error.
> See this for more details: http://pastie.org/private/yzxbnvxwidajalcucwflwa



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message