jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Gaul (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (JCLOUDS-454) NovaComputeService should query extensions to see if security groups are supported
Date Sat, 24 Jan 2015 11:26:35 GMT

     [ https://issues.apache.org/jira/browse/JCLOUDS-454?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Gaul updated JCLOUDS-454:
--------------------------------
    Labels: openstack-nova  (was: openstack)

> NovaComputeService should query extensions to see if security groups are supported
> ----------------------------------------------------------------------------------
>
>                 Key: JCLOUDS-454
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-454
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-compute
>            Reporter: Everett Toews
>            Priority: Minor
>              Labels: openstack-nova
>             Fix For: 2.0.0
>
>
> Right now NovaSecurityGroupExtension is injected into the NovaComputeService via NovaComputeServiceContextModule.
This is effectively an assumption that all OpenStack clouds support security groups. Some
may not.
> NovaComputeService should override getSecurityGroupExtension() and query extensions to
see if security groups are supported.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message