jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Gaul (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (JCLOUDS-714) Refactor TemplateOptions getGroups() method naming
Date Sat, 24 Jan 2015 11:25:35 GMT

     [ https://issues.apache.org/jira/browse/JCLOUDS-714?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Gaul updated JCLOUDS-714:
--------------------------------
    Labels:   (was: compute)

> Refactor TemplateOptions getGroups() method naming
> --------------------------------------------------
>
>                 Key: JCLOUDS-714
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-714
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-compute
>    Affects Versions: 1.6.0, 1.7.0, 1.8.0
>            Reporter: Jeremy Daggett
>            Priority: Minor
>
> The {{TemplateOptions.getGroups()}} method name is vague and confusing. It relates to
a  _security group_, and should be aptly renamed to {{TemplateOptions.getSecurityGroups()}}.
The old {{getGroups()}} accessor should be deprecated and slated for removal in 2.0.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message