jclouds-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCLOUDS-897) jclouds breaks with guice 4.0 because rocoto is evil
Date Thu, 21 May 2015 10:05:00 GMT

    [ https://issues.apache.org/jira/browse/JCLOUDS-897?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14554018#comment-14554018
] 

ASF subversion and git services commented on JCLOUDS-897:
---------------------------------------------------------

Commit 7053a7870da15c3996ca0fd6567f398ac9a5dfb0 in jclouds's branch refs/heads/master from
[~nacx]
[ https://git-wip-us.apache.org/repos/asf?p=jclouds.git;h=7053a78 ]

JCLOUDS-897: Remove the Rocoto dependency


> jclouds breaks with guice 4.0 because rocoto is evil
> ----------------------------------------------------
>
>                 Key: JCLOUDS-897
>                 URL: https://issues.apache.org/jira/browse/JCLOUDS-897
>             Project: jclouds
>          Issue Type: Bug
>          Components: jclouds-core
>    Affects Versions: 1.9.0
>            Reporter: Ben McCann
>            Assignee: Ignasi Barrera
>
> Rocoto is a horrible, horrible library. It uses com.google.inject.internal.util.$Preconditions,
which you quite obviously should not do. This has been a known issue for years (https://github.com/99soft/rocoto/issues/7),
but has not been fixed yet. In fact, the library is completely un-maintained with no commits
since 2012. I would love it if we could get rid of this dependency since pulling it in is
breaking my project.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message